summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-13 00:32:43 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-13 00:32:43 +0200
commitb126c613959c119f6a57123bd921c2a5395767a0 (patch)
tree73bd5e228f8f9ba74bde638efeaba242b458ae04
parentf92e15fbe52427e51260f60fe902da18ae85fd2a (diff)
downloadopenwrt-personal-pkgs-b126c613959c119f6a57123bd921c2a5395767a0.tar.gz
openwrt-personal-pkgs-b126c613959c119f6a57123bd921c2a5395767a0.tar.bz2
openwrt-personal-pkgs-b126c613959c119f6a57123bd921c2a5395767a0.zip
Add python3-jsonpath-ng
-rw-r--r--bigclown-mqtt2influxdb/Makefile2
-rw-r--r--python3-jsonpath-ng/Makefile24
2 files changed, 25 insertions, 1 deletions
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
index 678461f..d8b6405 100644
--- a/bigclown-mqtt2influxdb/Makefile
+++ b/bigclown-mqtt2influxdb/Makefile
@@ -11,7 +11,7 @@ $(call include_mk, python3-package.mk)
define Package/$(PKG_NAME)
TITLE:=BigCLown MQTT to Influxdb bridge
- DEPENDS:=+python3 +python3-paho-mqtt +python3-influxdb
+ DEPENDS:=+python3 +python3-paho-mqtt +python3-influxdb +python3-jsonpath-ng
endef
define Py3Package/$(PKG_NAME)/install
diff --git a/python3-jsonpath-ng/Makefile b/python3-jsonpath-ng/Makefile
new file mode 100644
index 0000000..14de303
--- /dev/null
+++ b/python3-jsonpath-ng/Makefile
@@ -0,0 +1,24 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-jsonpath-ng
+PKG_VERSION:=1.4.2
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://github.com/h2non/jsonpath-ng/archive/v$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=aa3162e145a7c5cab58662f49db7aecf
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Python composable command line utility
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))