summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-11-27 22:26:00 +0100
committerKarel Kočí <karel.koci@nic.cz>2018-11-28 11:18:30 +0100
commitaa6c1f7ddf512f719037d1f6bba1c56adf92777c (patch)
treece2bc3b521b4094562dea017cbe9a1c240c1dae2
parent22ca6212993dec46c1b32df68f91db59ff46605c (diff)
downloadopenwrt-personal-pkgs-aa6c1f7ddf512f719037d1f6bba1c56adf92777c.tar.gz
openwrt-personal-pkgs-aa6c1f7ddf512f719037d1f6bba1c56adf92777c.tar.bz2
openwrt-personal-pkgs-aa6c1f7ddf512f719037d1f6bba1c56adf92777c.zip
personal-pkgs-repo: add additional packages
-rw-r--r--personal-pkgs-repo/Makefile2
-rw-r--r--personal-pkgs-repo/files/updater.lua21
2 files changed, 22 insertions, 1 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 2c28564..0eac30d 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.3
+PKG_VERSION:=1.4
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
diff --git a/personal-pkgs-repo/files/updater.lua b/personal-pkgs-repo/files/updater.lua
index 2bf7636..228969d 100644
--- a/personal-pkgs-repo/files/updater.lua
+++ b/personal-pkgs-repo/files/updater.lua
@@ -6,13 +6,34 @@ elseif model:match('^[Tt]urris$') then
else
DIE("Unsupported board!")
end
+local hostname_file = io.open('/proc/sys/kernel/hostname')
+local hostname = hostname_file:read()
+hostname_file:close()
Repository("personal-pkgs", "https://cynerd.cz/repo/turris3x/" .. board, {
pubkey = "file:///etc/updater/keys/personal-pkgs.pub",
ocsp = false
})
+-- Core package
Install("personal-pkgs-repo")
Package("personal-pkgs-repo", { replan = "finished" })
+-- Shells
Install("shellrc-zsh", "shellrc-ash")
+
+-- VPNs
+Install("luci-app-openvpn", "openvpn-openssl")
+Install("luci-app-wireguard", "wireguard")
+
+-- Basic additional tools
+Install("grep", "coreutils-sha256sum")
+Install("iperf", "iperf3")
+Install("sysstat", "strace", "gdbserver")
+
+if hostname == "turris-home" then
+ Install("transmission-daemon-openssl")
+end
+
+-- Sentinel!
+Install("sentinel-minipot")