summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-01-31 16:52:57 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-01-31 16:52:57 +0100
commit9209c372dd43a3b0343a6f2b5625abf7124b44b4 (patch)
tree61fea9cc69d2ad9158817345520eeda6bc64f4ea
parent2c5b7b642f12df2ab287f8fde2338e60917041cd (diff)
downloadopenwrt-personal-pkgs-9209c372dd43a3b0343a6f2b5625abf7124b44b4.tar.gz
openwrt-personal-pkgs-9209c372dd43a3b0343a6f2b5625abf7124b44b4.tar.bz2
openwrt-personal-pkgs-9209c372dd43a3b0343a6f2b5625abf7124b44b4.zip
personal-pkgs-repo: Add request to install turtris
-rw-r--r--personal-pkgs-repo/Makefile2
-rw-r--r--personal-pkgs-repo/files/updater.lua17
2 files changed, 18 insertions, 1 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 6b9b9c0..5d95858 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.5
+PKG_VERSION:=1.6
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
diff --git a/personal-pkgs-repo/files/updater.lua b/personal-pkgs-repo/files/updater.lua
index 5cf6d97..5c4deae 100644
--- a/personal-pkgs-repo/files/updater.lua
+++ b/personal-pkgs-repo/files/updater.lua
@@ -37,6 +37,23 @@ if hostname == "turris-home" then
elseif hostname == "turris-prague" then
Install("6to4")
end
+-- Turtris
+local turtris = {
+ ["0000000B00005F64"] = true,
+ ["0000000B00007C39"] = true,
+ ["0000000B00007C65"] = true,
+ ["0000000B00011807"] = true,
+ ["0000000B00001C5C"] = true,
+ ["0000000B0000EDBF"] = true,
+ ["0000000B0000F17C"] = true,
+ ["0000000B0000EA2E"] = true,
+ ["0000000B00005BA7"] = true,
+}
+if serial == "0000000B0000EB0A" then
+ Install("turtetris-master")
+elseif turtris[serial] then
+ Install("turtetris-slave")
+end
-- Sentinel!
Install("sentinel-minipot")