summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-13 14:44:52 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-13 14:44:52 +0200
commit79ecb07a3ce224b574e9cdfc1fe264d8a4902cb6 (patch)
treede68a9452afba0c40101d4973eb5d5dfa7aeb221
parent5e0641470fb4989671969ef3ffd5aca97e3dfd19 (diff)
downloadopenwrt-personal-pkgs-79ecb07a3ce224b574e9cdfc1fe264d8a4902cb6.tar.gz
openwrt-personal-pkgs-79ecb07a3ce224b574e9cdfc1fe264d8a4902cb6.tar.bz2
openwrt-personal-pkgs-79ecb07a3ce224b574e9cdfc1fe264d8a4902cb6.zip
python3-reqiest: update to new version
-rw-r--r--python3-requests/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/python3-requests/Makefile b/python3-requests/Makefile
new file mode 100644
index 0000000..bd43a33
--- /dev/null
+++ b/python3-requests/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-requests
+PKG_VERSION:=2.19.1
+PKG_RELEASE:=2
+
+PKG_SOURCE:=requests-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/r/requests/
+PKG_MD5SUM:=6c1a31afec9d614e2e71a91ee6ca2878
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/requests-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python3-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/python3-requests
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python HTTP for Humans.
+ URL:=http://python-requests.org
+ DEPENDS:=+python3
+endef
+
+define Package/python3-requests/description
+ Python HTTP for Humans.
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,, \
+ install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
+ --single-version-externally-managed \
+ )
+endef
+
+$(eval $(call Py3Package,python3-requests))
+$(eval $(call BuildPackage,python3-requests))