summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-01-28 16:08:46 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-01-28 16:08:46 +0100
commit6bbdc0b08b0f1803e608be4b388b55ff83f8cda8 (patch)
tree19587900403c863953b05b21213559f5ba649542
parent7c9667e6b6ae813f76547d84adda4f4690579bf1 (diff)
downloadopenwrt-personal-pkgs-6bbdc0b08b0f1803e608be4b388b55ff83f8cda8.tar.gz
openwrt-personal-pkgs-6bbdc0b08b0f1803e608be4b388b55ff83f8cda8.tar.bz2
openwrt-personal-pkgs-6bbdc0b08b0f1803e608be4b388b55ff83f8cda8.zip
updater-ng: update to use 3.x specific branch
-rw-r--r--updater-ng/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 562eb46..325e825 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -1,5 +1,5 @@
#
-## Copyright (C) 2016-2017 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+## Copyright (C) 2016-2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
#
## This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater.git
-PKG_SOURCE_BRANCH:=master
+PKG_SOURCE_BRANCH:=for-turris-3x
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
PKG_BUILD_DEPENDS:=busybox
@@ -166,6 +166,8 @@ define Package/$(PKG_NAME)-opkg/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/localrepo/content2localrepo $(1)/usr/share/updater/opkg-content2localrepo.sh
$(INSTALL_DIR) $(1)/etc/updater/conf.d
$(INSTALL_CONF) $(PKG_BUILD_DIR)/src/opkg-wrapper/opkg.lua $(1)/etc/updater/conf.d/opkg.lua
+ $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
+ touch $(1)/etc/updater/opkg-ignore/.keep
endef
# We are calling migration to localrepo from updater-ng-opkg package posinst as