summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-17 10:16:50 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-17 10:16:50 +0200
commit60fa656371b79eb796c3df7bba53c547d5e17557 (patch)
treefb302d4b4efccbf93c21c6626ba99d1b3c5498c7
parentaaf23c38eaaa9064b4bf4ad08e4566ea3680b096 (diff)
downloadopenwrt-personal-pkgs-60fa656371b79eb796c3df7bba53c547d5e17557.tar.gz
openwrt-personal-pkgs-60fa656371b79eb796c3df7bba53c547d5e17557.tar.bz2
openwrt-personal-pkgs-60fa656371b79eb796c3df7bba53c547d5e17557.zip
In some of the Python3 packages use pypi instead of github
-rw-r--r--python3-dateutil/Makefile7
-rw-r--r--python3-influxdb/Makefile6
-rw-r--r--python3-jsonpath-ng/Makefile10
-rw-r--r--python3-pyserial/Makefile7
-rw-r--r--python3-requests/Makefile7
-rw-r--r--python3-six/Makefile7
6 files changed, 10 insertions, 34 deletions
diff --git a/python3-dateutil/Makefile b/python3-dateutil/Makefile
index 96a637e..357590f 100644
--- a/python3-dateutil/Makefile
+++ b/python3-dateutil/Makefile
@@ -1,10 +1,3 @@
-#
-# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-dateutil
diff --git a/python3-influxdb/Makefile b/python3-influxdb/Makefile
index 56d61a3..6f360e3 100644
--- a/python3-influxdb/Makefile
+++ b/python3-influxdb/Makefile
@@ -1,8 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-influxdb
+PKG_VERSION:=5.2.0
PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://github.com/influxdata/influxdb-python.git
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/i/influxdb/
+PKG_SOURCE:=influxdb-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=8d82a3e48c8d20f4d1f1243c6bb04402
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
include $(TOPDIR)/package/autopkg-tag.mk
diff --git a/python3-jsonpath-ng/Makefile b/python3-jsonpath-ng/Makefile
index 78bc42a..2c55565 100644
--- a/python3-jsonpath-ng/Makefile
+++ b/python3-jsonpath-ng/Makefile
@@ -2,13 +2,13 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python3-jsonpath-ng
PKG_VERSION:=1.4.3
-PKG_GIT_VERSION:=003a0b78f8a1857aa7027a837def54564a2b578a
PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://github.com/h2non/jsonpath-ng/archive/$(PKG_GIT_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MDSUM:=bcc11792f1877b60ad267b7eb3c1e3b6
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/j/jsonpath-ng/
+PKG_SOURCE:=jsonpath-ng-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=cb507b93e1e9b81c6f2e01061eeb2098
+PKG_BUILD_DIR:=$(BUILD_DIR)/jsonpath-ng-$(PKG_VERSION)
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-PKG_BUILD_DIR:=$(BUILD_DIR)/jsonpath-ng-$(PKG_GIT_VERSION)
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python3-package.mk)
diff --git a/python3-pyserial/Makefile b/python3-pyserial/Makefile
index 2ccd867..d1d8aaf 100644
--- a/python3-pyserial/Makefile
+++ b/python3-pyserial/Makefile
@@ -1,10 +1,3 @@
-#
-# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-pyserial
diff --git a/python3-requests/Makefile b/python3-requests/Makefile
index e1aa5bf..f7a97ee 100644
--- a/python3-requests/Makefile
+++ b/python3-requests/Makefile
@@ -1,10 +1,3 @@
-#
-# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-requests
diff --git a/python3-six/Makefile b/python3-six/Makefile
index dfa662d..1aa2938 100644
--- a/python3-six/Makefile
+++ b/python3-six/Makefile
@@ -1,10 +1,3 @@
-#
-# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
include $(TOPDIR)/rules.mk
PKG_NAME:=python3-six