summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-13 14:38:36 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-13 14:38:36 +0200
commit5e0641470fb4989671969ef3ffd5aca97e3dfd19 (patch)
tree62e947945e1fe2a4cc3fb33194dcae66bb87a40a
parenteedc2cda3c3df22f882fee9c45f52a9dd24cc1b7 (diff)
downloadopenwrt-personal-pkgs-5e0641470fb4989671969ef3ffd5aca97e3dfd19.tar.gz
openwrt-personal-pkgs-5e0641470fb4989671969ef3ffd5aca97e3dfd19.tar.bz2
openwrt-personal-pkgs-5e0641470fb4989671969ef3ffd5aca97e3dfd19.zip
Try python3-six updated version
-rw-r--r--python3-six/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/python3-six/Makefile b/python3-six/Makefile
new file mode 100644
index 0000000..dfa662d
--- /dev/null
+++ b/python3-six/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-six
+PKG_VERSION:=1.11.0
+PKG_RELEASE:=2
+
+PKG_SOURCE:=six-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/six/
+PKG_MD5SUM:=d12789f9baf7e9fb2524c0c64f1773f8
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/six-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python3-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/python3-six
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python 2 and 3 compatibility utilities
+ URL:=http://pypi.python.org/pypi/six/
+ DEPENDS:=+python3
+endef
+
+define Package/python3-six/description
+ Python 2 and 3 compatibility utilities
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,, \
+ install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
+ --single-version-externally-managed \
+ )
+endef
+
+$(eval $(call Py3Package,python3-six))
+$(eval $(call BuildPackage,python3-six))