summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-13 15:37:27 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-13 15:37:27 +0200
commit5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f (patch)
tree21f35fe49cf672e278aa6c92d2550dde7252a1ba
parent7957fff23ca027a9bae3ae5f66dc934cee815650 (diff)
downloadopenwrt-personal-pkgs-5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f.tar.gz
openwrt-personal-pkgs-5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f.tar.bz2
openwrt-personal-pkgs-5cd5bed1c32e2d3cc92b91092c3a7a317e747b3f.zip
python3-requests: add missing dependencies
-rw-r--r--python3-certifi/Makefile26
-rw-r--r--python3-chardet/Makefile26
-rw-r--r--python3-idna/Makefile26
-rw-r--r--python3-requests/Makefile2
-rw-r--r--python3-urllib3/Makefile26
5 files changed, 105 insertions, 1 deletions
diff --git a/python3-certifi/Makefile b/python3-certifi/Makefile
new file mode 100644
index 0000000..e51f02f
--- /dev/null
+++ b/python3-certifi/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-certifi
+PKG_VERSION:=2018.8.24
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/certifi/
+PKG_SOURCE:=certifi-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=c6be18cddd339c893131d992e13949c1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/certifi-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Collection of Root Certificates for validating the trustworthiness of SSL certificates
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/python3-chardet/Makefile b/python3-chardet/Makefile
new file mode 100644
index 0000000..9a7fc6a
--- /dev/null
+++ b/python3-chardet/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-chardet
+PKG_VERSION:=3.0.4
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/chardet/
+PKG_SOURCE:=chardet-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=7dd1ba7f9c77e32351b0a0cfacf4055c
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/charder-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=The Universal Character Encoding Detector
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/python3-idna/Makefile b/python3-idna/Makefile
new file mode 100644
index 0000000..7fc41ff
--- /dev/null
+++ b/python3-idna/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-idna
+PKG_VERSION:=2.7
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/i/idna/
+PKG_SOURCE:=chardet-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=0e5bb69018ddef1b9d95f681182be82c
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/idna-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Support for the Internationalised Domain Names in Applications
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/python3-requests/Makefile b/python3-requests/Makefile
index bd43a33..c2d2b53 100644
--- a/python3-requests/Makefile
+++ b/python3-requests/Makefile
@@ -27,7 +27,7 @@ define Package/python3-requests
CATEGORY:=Languages
TITLE:=Python HTTP for Humans.
URL:=http://python-requests.org
- DEPENDS:=+python3
+ DEPENDS:=+python3 +python3-charder +python3-idna +python3-urllib3 +python3-certifi
endef
define Package/python3-requests/description
diff --git a/python3-urllib3/Makefile b/python3-urllib3/Makefile
new file mode 100644
index 0000000..17057b0
--- /dev/null
+++ b/python3-urllib3/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-urllib3
+PKG_VERSION:=3.0.4
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/u/urllib3/
+PKG_SOURCE:=urllib3-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=1ad43e4b5ab7a0794c89dc057e1d7179
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/urllib3-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=A powerful, sanity-friendly HTTP client for Python
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))