summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-13 15:03:02 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-13 15:03:02 +0200
commit5b51fb7fe1ffd717eb83738102eda2c907a5636f (patch)
treef454f4cca8775370cfadbda443f9644662e5073e
parent79ecb07a3ce224b574e9cdfc1fe264d8a4902cb6 (diff)
downloadopenwrt-personal-pkgs-5b51fb7fe1ffd717eb83738102eda2c907a5636f.tar.gz
openwrt-personal-pkgs-5b51fb7fe1ffd717eb83738102eda2c907a5636f.tar.bz2
openwrt-personal-pkgs-5b51fb7fe1ffd717eb83738102eda2c907a5636f.zip
Add some missing dependencies for influxdb
-rw-r--r--python3-dateutil/Makefile44
-rw-r--r--python3-influxdb/Makefile2
2 files changed, 45 insertions, 1 deletions
diff --git a/python3-dateutil/Makefile b/python3-dateutil/Makefile
new file mode 100644
index 0000000..f1ad0d3
--- /dev/null
+++ b/python3-dateutil/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2015 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-dateutil
+PKG_VERSION:=2.7.3
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/r/python-dateutil/
+PKG_SOURCE:=python-dateutil-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=175b7c1a3cc0cb01151eced07c61c0b8
+PKG_BUILD_DIR:=$(BUILD_DIR)/python-dateutil-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python3-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python powerful extensions to datetime
+ URL:=https://dateutil.readthedocs.io/en/stable/
+ DEPENDS:=+python3 +python3-six
+endef
+
+define Package/$(PKG_NAME)/description
+ Python powerful extensions to datetime
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,, \
+ install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
+ --single-version-externally-managed \
+ )
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/python3-influxdb/Makefile b/python3-influxdb/Makefile
index 7cdd0cb..56d61a3 100644
--- a/python3-influxdb/Makefile
+++ b/python3-influxdb/Makefile
@@ -11,7 +11,7 @@ $(call include_mk, python3-package.mk)
define Package/$(PKG_NAME)
TITLE:=Python client for InfluxDB
- DEPENDS:=+python3
+ DEPENDS:=+python3 +python3-requests +python3-pytz +python3-six +python3-dateutil
endef
define Build/Compile