summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-01-31 16:03:26 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-01-31 16:03:26 +0100
commit2c5b7b642f12df2ab287f8fde2338e60917041cd (patch)
treeaa97f7191d8512ed7ec8b4078c3eb7fd3dcb0de5
parentc46cedfc312828831614ece2f365b53f07ddeb42 (diff)
downloadopenwrt-personal-pkgs-2c5b7b642f12df2ab287f8fde2338e60917041cd.tar.gz
openwrt-personal-pkgs-2c5b7b642f12df2ab287f8fde2338e60917041cd.tar.bz2
openwrt-personal-pkgs-2c5b7b642f12df2ab287f8fde2338e60917041cd.zip
Drop python-uci
-rw-r--r--python-uci/Makefile60
1 files changed, 0 insertions, 60 deletions
diff --git a/python-uci/Makefile b/python-uci/Makefile
deleted file mode 100644
index a4017be..0000000
--- a/python-uci/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-#
-# Copyright (C) 2018 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-uci
-PKG_LICENSE:=GPLv3
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/pyuci.git
-PKG_SOURCE_BRANCH:=add-euci
-PKG_BUILD_DEPENDS:=python-setuptools python3-setuptools
-
-include $(TOPDIR)/package/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python-package.mk)
-$(call include_mk, python3-package.mk)
-
-define Package/Common
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- URL:=https://gitlab.labs.nic.cz/turris/pyuci/
- MAINTAINER:=CZ.NIC <packaging@turris.cz>
-endef
-
-define Package/python-uci
- $(call Package/Common)
- TITLE:=python-uci
- DEPENDS:=+python-light +libuci
-endef
-
-define Package/python3-uci
- $(call Package/Common)
- TITLE:=python3-uci
- DEPENDS:=+python3-light +libuci
-endef
-
-define Package/$(PKG_NAME)/description
- Python bindings for Unified Configuration Interface.
-endef
-
-define Build/Compile
- $(call Build/Compile/PyMod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR)/py2)
- $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR)/py3)
-endef
-
-PKG_INSTALL_DIR_ORIG:="$(PKG_INSTALL_DIR)"
-PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)/py2"
-$(eval $(call PyPackage,python-uci))
-PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)/py3"
-$(eval $(call Py3Package,python3-uci))
-PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)"
-
-$(eval $(call BuildPackage,python-uci))
-$(eval $(call BuildPackage,python3-uci))