summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-01-31 14:58:33 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-01-31 14:58:33 +0100
commit16f1c6982db08545b6e3eaa5c2e5e4fa5879699b (patch)
treea10c5376341824f1df24dc4d8a2cfdb849d4360c
parentbe8c8147556162c9ff2aa206ca06632b21143ccb (diff)
downloadopenwrt-personal-pkgs-16f1c6982db08545b6e3eaa5c2e5e4fa5879699b.tar.gz
openwrt-personal-pkgs-16f1c6982db08545b6e3eaa5c2e5e4fa5879699b.tar.bz2
openwrt-personal-pkgs-16f1c6982db08545b6e3eaa5c2e5e4fa5879699b.zip
Add pyuci package
-rw-r--r--python-uci/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/python-uci/Makefile b/python-uci/Makefile
new file mode 100644
index 0000000..c724bf7
--- /dev/null
+++ b/python-uci/Makefile
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2018 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-uci
+PKG_LICENSE:=GPLv3
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/pyuci.git
+PKG_SOURCE_BRANCH:=master
+PKG_BUILD_DEPENDS:=python-setuptools python3-setuptools
+
+include $(TOPDIR)/package/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
+
+define Package/Common
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ URL:=https://gitlab.labs.nic.cz/turris/pyuci/
+ MAINTAINER:=CZ.NIC <packaging@turris.cz>
+endef
+
+define Package/python-uci
+ $(call Package/Common)
+ TITLE:=python-uci
+ DEPENDS:=+python-light +libuci
+endef
+
+define Package/python3-uci
+ $(call Package/Common)
+ TITLE:=python3-uci
+ DEPENDS:=+python3-light +libuci
+endef
+
+define Package/$(PKG_NAME)/description
+ Python bindings for Unified Configuration Interface.
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR)/py2)
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR)/py3)
+endef
+
+PKG_INSTALL_DIR_ORIG:="$(PKG_INSTALL_DIR)"
+PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)/py2"
+$(eval $(call PyPackage,python-uci))
+PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)/py3"
+$(eval $(call Py3Package,python3-uci))
+PKG_INSTALL_DIR:="$(PKG_INSTALL_DIR_ORIG)"
+
+$(eval $(call BuildPackage,python-uci))
+$(eval $(call BuildPackage,python3-uci))