aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sentinel/proxy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sentinel/proxy/default.nix')
-rw-r--r--pkgs/sentinel/proxy/default.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/pkgs/sentinel/proxy/default.nix b/pkgs/sentinel/proxy/default.nix
index 5de2836..a3b6bf2 100644
--- a/pkgs/sentinel/proxy/default.nix
+++ b/pkgs/sentinel/proxy/default.nix
@@ -1,6 +1,7 @@
{ stdenv, lib, fetchgit
-, autoconf, autoconf-archive, automake, libtool, pkgconfig, gperf
+, bootstrapHook, pkg-config, gperf
, openssl, zlib, czmq, libconfig, msgpack, paho-mqtt-c
+, check
}:
stdenv.mkDerivation rec {
@@ -9,7 +10,6 @@ stdenv.mkDerivation rec {
meta = with lib; {
homepage = "https://gitlab.nic.cz/turris/sentinel/proxy";
description = "Main MQTT Sentinel client. Proxy that lives on the router and relays messages received from ZMQ to uplink server over MQTT channel.";
- platforms = with platforms; linux;
license = licenses.gpl3;
};
@@ -20,9 +20,12 @@ stdenv.mkDerivation rec {
};
buildInputs = [openssl zlib czmq libconfig msgpack paho-mqtt-c];
- nativeBuildInputs = [
- autoconf autoconf-archive automake libtool pkgconfig gperf
- ];
+ nativeBuildInputs = [bootstrapHook pkg-config gperf];
+ depsBuildBuild = [check];
preConfigure = "./bootstrap";
+
+ doCheck = true;
+ doInstallCheck = true;
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
}