aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sentinel/faillogs
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sentinel/faillogs')
-rw-r--r--pkgs/sentinel/faillogs/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/sentinel/faillogs/default.nix b/pkgs/sentinel/faillogs/default.nix
index d4bfa6b..4b3a2d3 100644
--- a/pkgs/sentinel/faillogs/default.nix
+++ b/pkgs/sentinel/faillogs/default.nix
@@ -1,6 +1,7 @@
{ stdenv, lib, fetchgit
, bootstrapHook, pkg-config, gperf
, logc, logc-libs, libevent, czmq, msgpack, libconfig
+, check
}:
stdenv.mkDerivation rec {
@@ -9,7 +10,6 @@ stdenv.mkDerivation rec {
meta = with lib; {
homepage = "https://gitlab.nic.cz/turris/sentinel/faillogs";
description = "Failed login attempt logs collector";
- platforms = with platforms; linux;
license = licenses.gpl3;
};
@@ -21,4 +21,9 @@ stdenv.mkDerivation rec {
buildInputs = [logc logc-libs libevent czmq msgpack libconfig];
nativeBuildInputs = [bootstrapHook pkg-config gperf];
+ depsBuildBuild = [check];
+
+ doCheck = true;
+ doInstallCheck = true;
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
}