aboutsummaryrefslogtreecommitdiff
path: root/pkgs/libraries/logc
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/libraries/logc')
-rw-r--r--pkgs/libraries/logc/0001-configure.ac-fix-cross-compilation.patch28
-rw-r--r--pkgs/libraries/logc/default.nix10
2 files changed, 37 insertions, 1 deletions
diff --git a/pkgs/libraries/logc/0001-configure.ac-fix-cross-compilation.patch b/pkgs/libraries/logc/0001-configure.ac-fix-cross-compilation.patch
new file mode 100644
index 0000000..3c0fafe
--- /dev/null
+++ b/pkgs/libraries/logc/0001-configure.ac-fix-cross-compilation.patch
@@ -0,0 +1,28 @@
+From 7105fb9859f4d3264dbaaee5dc7596c561dc3e1a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <karel.koci@nic.cz>
+Date: Tue, 4 Jan 2022 18:38:38 +0100
+Subject: [PATCH] configure.ac: fix cross compilation
+
+The AC_CHECK_FILE is not supported when cross compiling. We can just use
+plain AS_IF with test for the same effect.
+---
+ CHANGELOG.md | 1 +
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5946a53..b6d42ea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,7 +18,7 @@ PKG_INSTALLDIR
+ AX_CHECK_COMPILE_FLAG([-std=c11], , AC_MSG_ERROR([Compiler with C11 standard support is required]))
+ AX_APPEND_FLAG([-std=c11])
+
+-AC_CHECK_FILE([${0%/*}/bootstrap],[
++AS_IF([test -x "${0%/*}/bootstrap" ],[
+ AC_PATH_PROG([GPERF], [gperf])
+ AS_IF([test -z "$GPERF"], [AC_MSG_ERROR([Missing gperf generator])])
+ ])
+--
+2.35.1
+
diff --git a/pkgs/libraries/logc/default.nix b/pkgs/libraries/logc/default.nix
index 784efd7..6ffd8f4 100644
--- a/pkgs/libraries/logc/default.nix
+++ b/pkgs/libraries/logc/default.nix
@@ -1,6 +1,7 @@
{ stdenv, lib, fetchgit
, bootstrapHook, pkg-config, gperf
, libconfig
+, check
}:
stdenv.mkDerivation rec {
@@ -9,7 +10,6 @@ stdenv.mkDerivation rec {
meta = with lib; {
homepage = "https://gitlab.nic.cz/turris/logc";
description = "Logging for C";
- platforms = with platforms; linux;
license = licenses.mit;
};
@@ -18,7 +18,15 @@ stdenv.mkDerivation rec {
rev = "v" + version;
sha256 = "15nplgjgg6dxryy4yzbj4524y77ci0syi970rmbr955m9vxvhrib";
};
+ patches = [
+ ./0001-configure.ac-fix-cross-compilation.patch
+ ];
buildInputs = [libconfig];
nativeBuildInputs = [bootstrapHook pkg-config gperf];
+ depsBuildBuild = [check];
+
+ doCheck = true;
+ doInstallCheck = true;
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
}