aboutsummaryrefslogtreecommitdiff
path: root/pkgs/libraries/logc/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/libraries/logc/default.nix')
-rw-r--r--pkgs/libraries/logc/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/libraries/logc/default.nix b/pkgs/libraries/logc/default.nix
index 784efd7..6ffd8f4 100644
--- a/pkgs/libraries/logc/default.nix
+++ b/pkgs/libraries/logc/default.nix
@@ -1,6 +1,7 @@
{ stdenv, lib, fetchgit
, bootstrapHook, pkg-config, gperf
, libconfig
+, check
}:
stdenv.mkDerivation rec {
@@ -9,7 +10,6 @@ stdenv.mkDerivation rec {
meta = with lib; {
homepage = "https://gitlab.nic.cz/turris/logc";
description = "Logging for C";
- platforms = with platforms; linux;
license = licenses.mit;
};
@@ -18,7 +18,15 @@ stdenv.mkDerivation rec {
rev = "v" + version;
sha256 = "15nplgjgg6dxryy4yzbj4524y77ci0syi970rmbr955m9vxvhrib";
};
+ patches = [
+ ./0001-configure.ac-fix-cross-compilation.patch
+ ];
buildInputs = [libconfig];
nativeBuildInputs = [bootstrapHook pkg-config gperf];
+ depsBuildBuild = [check];
+
+ doCheck = true;
+ doInstallCheck = true;
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
}