aboutsummaryrefslogtreecommitdiff
path: root/pkgs/libraries/logc-libs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/libraries/logc-libs/default.nix')
-rw-r--r--pkgs/libraries/logc-libs/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/libraries/logc-libs/default.nix b/pkgs/libraries/logc-libs/default.nix
index 1fe7a18..f8e4a57 100644
--- a/pkgs/libraries/logc-libs/default.nix
+++ b/pkgs/libraries/logc-libs/default.nix
@@ -1,6 +1,7 @@
{ stdenv, lib, fetchgit
, bootstrapHook, pkg-config
, logc, czmq, libevent
+, check
}:
stdenv.mkDerivation rec {
@@ -9,7 +10,6 @@ stdenv.mkDerivation rec {
meta = with lib; {
homepage = "https://gitlab.nic.cz/turris/logc-libs";
description = "Logging for C";
- platforms = with platforms; linux;
license = licenses.mit;
};
@@ -21,4 +21,9 @@ stdenv.mkDerivation rec {
buildInputs = [logc czmq libevent];
nativeBuildInputs = [bootstrapHook pkg-config];
+ depsBuildBuild = [check];
+
+ doCheck = false; # TODO the test fails due to errno being set by czmq for some reason
+ doInstallCheck = false;
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
}