aboutsummaryrefslogtreecommitdiff
path: root/pkgs/shvspy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shvspy/default.nix')
-rw-r--r--pkgs/shvspy/default.nix81
1 files changed, 47 insertions, 34 deletions
diff --git a/pkgs/shvspy/default.nix b/pkgs/shvspy/default.nix
index edc0bd4..7f5e31d 100644
--- a/pkgs/shvspy/default.nix
+++ b/pkgs/shvspy/default.nix
@@ -1,39 +1,52 @@
-{ lib, stdenv, fetchFromGitHub
-, cmake, doctest, libsForQt5, qcoro_task_exception_handling
-, makeDesktopItem, copyDesktopItems
+{
+ lib,
+ stdenv,
+ fetchFromGitHub,
+ cmake,
+ doctest,
+ libsForQt5,
+ qcoro_task_exception_handling,
+ makeDesktopItem,
+ copyDesktopItems,
}:
-with libsForQt5;
+with libsForQt5;
+ stdenv.mkDerivation rec {
+ name = "shvspy";
-stdenv.mkDerivation rec {
- name = "shvspy";
+ src = fetchFromGitHub {
+ owner = "silicon-heaven";
+ repo = "shvspy";
+ rev = "a922e963bf7884164fe2b124a7a4366f7fc802a3";
+ sha256 = "ExA+sFlkxFKXk69DKoGzKm80ypiNFwN281MwZkMgaVY=";
+ fetchSubmodules = true;
+ };
- src = fetchFromGitHub {
- owner = "silicon-heaven";
- repo = "shvspy";
- rev = "a922e963bf7884164fe2b124a7a4366f7fc802a3";
- sha256 = "ExA+sFlkxFKXk69DKoGzKm80ypiNFwN281MwZkMgaVY=";
- fetchSubmodules = true;
- };
+ nativeBuildInputs = [
+ cmake
+ doctest
+ wrapQtAppsHook
+ copyDesktopItems
+ ];
+ buildInputs = [
+ qtbase
+ qtserialport
+ qtwebsockets
+ doctest
+ qcoro_task_exception_handling
+ ];
- nativeBuildInputs = [
- cmake doctest wrapQtAppsHook copyDesktopItems
- ];
- buildInputs = [
- qtbase qtserialport qtwebsockets doctest qcoro_task_exception_handling
- ];
+ desktopItems = [
+ (makeDesktopItem {
+ name = "shvspy";
+ exec = "shvspy";
+ desktopName = "SHVSpy";
+ categories = ["Network" "RemoteAccess"];
+ })
+ ];
- desktopItems = [
- (makeDesktopItem {
- name = "shvspy";
- exec = "shvspy";
- desktopName = "SHVSpy";
- categories = [ "Network" "RemoteAccess" ];
- })
- ];
-
- meta = with lib; {
- description = "Console version of Stardict program";
- homepage = "https://dushistov.github.io/sdcv/";
- license = licenses.gpl2;
- };
-}
+ meta = with lib; {
+ description = "Console version of Stardict program";
+ homepage = "https://dushistov.github.io/sdcv/";
+ license = licenses.gpl2;
+ };
+ }