aboutsummaryrefslogtreecommitdiff
path: root/pkgs/luks-hw-password/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/luks-hw-password/default.nix')
-rw-r--r--pkgs/luks-hw-password/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/luks-hw-password/default.nix b/pkgs/luks-hw-password/default.nix
new file mode 100644
index 0000000..9797735
--- /dev/null
+++ b/pkgs/luks-hw-password/default.nix
@@ -0,0 +1,20 @@
+{ lib, stdenvNoCC, makeWrapper
+, dmidecode, coreutils
+}:
+
+stdenvNoCC.mkDerivation {
+ pname = "luks-hw-password";
+ version = "1.0";
+ meta = with lib; {
+ license = licenses.gpl3;
+ platforms = platforms.linux;
+ };
+
+ nativeBuildInputs = [ makeWrapper ];
+ phases = [ "installPhase" ];
+ installPhase = ''
+ mkdir -p $out/bin
+ makeWrapper ${./luks-hw-password.sh} $out/bin/luks-hw-password \
+ --prefix PATH : ${lib.makeBinPath [ dmidecode coreutils ]}
+ '';
+}