aboutsummaryrefslogtreecommitdiff
path: root/pkgs/dev/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/dev/default.nix')
-rw-r--r--pkgs/dev/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/dev/default.nix b/pkgs/dev/default.nix
new file mode 100644
index 0000000..9238f4d
--- /dev/null
+++ b/pkgs/dev/default.nix
@@ -0,0 +1,29 @@
+{ lib, stdenvNoCC
+, makeShellWrapper, bash, nix
+, devShells
+}:
+
+with lib;
+
+let
+
+ shells = concatStringsSep ":" (mapAttrsToList (n: v: "${n}=${v}") devShells);
+
+in stdenvNoCC.mkDerivation rec {
+ name = "personal-devshells";
+ src = ./.;
+
+ nativeBuildInputs = [ makeShellWrapper ];
+ installPhase = ''
+ makeShellWrapper ${./dev.sh} $out/bin/dev \
+ --prefix PATH : ${lib.makeBinPath [ bash nix ]} \
+ --set DEV_SHELLS "${shells}" \
+ --set DEV_FLAKE "${../..}"
+ '';
+
+ meta = with lib; {
+ description = "Console version of Stardict program";
+ homepage = "https://dushistov.github.io/sdcv/";
+ license = licenses.gpl2;
+ };
+}