aboutsummaryrefslogtreecommitdiff
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index 56f23cc..e2363b0 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -1,10 +1,9 @@
{ self, nixpkgs }:
let
- pkgs = nixpkgs // personalpkgs;
- callPackage = nixpkgs.lib.callPackageWith pkgs;
+ callPackage = nixpkgs.newScope personalpkgs;
- personalpkgs = with pkgs; {
+ personalpkgs = rec {
luks-hw-password = callPackage ./luks-hw-password { };
@@ -22,11 +21,11 @@ let
sdcv = callPackage ./stardict/wrapper.nix { stardict = sdcv-unwrapped; };
# Package to be installed to the user's profile
- cynerd-profile = pkgs.symlinkJoin {
+ cynerd-profile = nixpkgs.symlinkJoin {
name = "cynerd-profile";
- paths = with pkgs; [
+ paths = [
self.inputs.shellrc.packages.${nixpkgs.system}.default
- tig
+ nixpkgs.tig
];
};