aboutsummaryrefslogtreecommitdiff
path: root/pkgs/cyrus-sasl-xoauth2/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/cyrus-sasl-xoauth2/default.nix')
-rw-r--r--pkgs/cyrus-sasl-xoauth2/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/cyrus-sasl-xoauth2/default.nix b/pkgs/cyrus-sasl-xoauth2/default.nix
new file mode 100644
index 0000000..2bd8713
--- /dev/null
+++ b/pkgs/cyrus-sasl-xoauth2/default.nix
@@ -0,0 +1,31 @@
+{ lib, stdenv, fetchFromGitHub
+, autoconf, automake, libtool, pkg-config
+, cyrus_sasl
+}:
+
+with lib;
+
+stdenv.mkDerivation rec {
+ pname = "cyrus-sasl-xoauth2";
+ version = "0.2";
+ src = fetchFromGitHub {
+ owner = "moriyoshi";
+ repo = "cyrus-sasl-xoauth2";
+ rev = "v${version}";
+ sha256 = "lI8uKtVxrziQ8q/Ss+QTgg1xTObZUTAzjL3MYmtwyd8=";
+ };
+
+ nativeBuildInputs = [
+ autoconf automake libtool pkg-config
+ ];
+ buildInputs = [
+ cyrus_sasl
+ ];
+
+ preConfigure = ''
+ ./autogen.sh
+ '';
+ installPhase = ''
+ make DESTDIR=$out install
+ '';
+}