aboutsummaryrefslogtreecommitdiff
path: root/devShells/c.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/c.nix')
-rw-r--r--devShells/c.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/devShells/c.nix b/devShells/c.nix
index 949b291..c1b5553 100644
--- a/devShells/c.nix
+++ b/devShells/c.nix
@@ -1,19 +1,20 @@
-{ nixpkgs, shellrc, system }:
+{ system, nixpkgs, default }:
let
pkgs = nixpkgs.legacyPackages.${system};
in pkgs.mkShell {
packages = (with pkgs; [
clang-tools
- gcc gdb
+ gcc gdb pkg-config
cppcheck flawfinder bear
meson
lcov massif-visualizer
]);
inputsFrom = with pkgs; [
check
+ curl
- shellrc.packages.${system}.default
+ default
];
meta.platforms = nixpkgs.lib.platforms.linux;
}