From 232d3a0bc9e336696536f3981eb4ba4eb725ddc8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Sun, 7 Jul 2019 20:55:25 +0200
Subject: sys-kernel/linux: update to 5.1.16

---
 sys-kernel/linux/Manifest               |  2 +-
 sys-kernel/linux/linux-5.1.14-r1.ebuild | 96 ---------------------------------
 sys-kernel/linux/linux-5.1.16-r1.ebuild | 96 +++++++++++++++++++++++++++++++++
 3 files changed, 97 insertions(+), 97 deletions(-)
 delete mode 100644 sys-kernel/linux/linux-5.1.14-r1.ebuild
 create mode 100644 sys-kernel/linux/linux-5.1.16-r1.ebuild

(limited to 'sys-kernel')

diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index af3ffa6..d36f5a9 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1 +1 @@
-DIST linux-5.1.14.tar.gz 166173871 BLAKE2B 5daa2d75fbcc6e1486c96ef524e44b19fa07629128dafdcfcbc9149b093d1f1c981da7a558dac787496241073b0f37fd681d9668c4d4380a0babd92bedd95766 SHA512 a1c5617cdf70c3af6fa1275fa576907088b7fc7f5eb1bc9c1dae2cedc68a5df1a105fcc0b2ff747fe776c1ab0988dafc65beb2f522834e00d22e535feecd7608
+DIST linux-5.1.16.tar.gz 166182796 BLAKE2B 423e2d294896bbc2b910d5579aee9f82078412f674f19d1bc81396e904bdeaaf756bd556d2213459b0aa05687db81dc85e5ebd80e43f5827d0e36d4cbc9dfd41 SHA512 1924304615002d37fd41ce471d021572b01108471a1c75ab2976aee64c85c979d9a8b9decf45f1cf3b1eb0d9041dcc78e2dd3d56712dd2398c5b8bb11c1c6d2a
diff --git a/sys-kernel/linux/linux-5.1.14-r1.ebuild b/sys-kernel/linux/linux-5.1.14-r1.ebuild
deleted file mode 100644
index 1c1c58c..0000000
--- a/sys-kernel/linux/linux-5.1.14-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="virt initramfs amd intel ucode"
-
-DEPEND="
-	sys-devel/bc
-	dev-libs/elfutils"
-
-src_configure() {
-	# Fix ARCH variable
-	[ "$ARCH" = "amd64" ] && ARCH="x86"
-
-	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
-		|| die "Configuration application failed"
-}
-
-src_install() {
-	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
-	dodir /boot
-	insinto /boot
-	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
-	# Package source (kind of annoying because of some packages expecting it)
-	emake clean
-	dodir /usr/src
-	cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
-	(
-	cd "${ROOT}/usr/src"
-	rm -f linux
-	ln -s $(ls | grep "linux-" | sort | tail -1) linux
-	)
-}
-
-sysfile() {
-	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
-	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
-	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
-		SYSLINUX="${ROOT}/boot/extlinux.conf"
-	else
-		eerror "Can't locate syslinux configuration!"
-	fi
-}
-
-pkg_postinst() {
-	# Add label to syslinux config if there is non yet
-	sysfile
-	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
-		if $(use initramfs); then
-			if $(use ucode); then
-				INITRD="\tINITRD /ucode.cpio,/initramfs-gentoo\n"
-			else
-				INITRD="\tINITRD /initramfs-gentoo\n"
-			fi
-		fi
-		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
-		if [ -n "$ARGS" ]; then
-			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
-			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
-		else
-			eerror "Adding label to syslinux configuration failed as there are no arguments"
-		fi
-	fi
-
-	src_link
-}
-
-pkg_prerm() {
-	# Remove label from syslinux config
-	sysfile
-	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
-	src_link
-}
diff --git a/sys-kernel/linux/linux-5.1.16-r1.ebuild b/sys-kernel/linux/linux-5.1.16-r1.ebuild
new file mode 100644
index 0000000..1c1c58c
--- /dev/null
+++ b/sys-kernel/linux/linux-5.1.16-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE="virt initramfs amd intel ucode"
+
+DEPEND="
+	sys-devel/bc
+	dev-libs/elfutils"
+
+src_configure() {
+	# Fix ARCH variable
+	[ "$ARCH" = "amd64" ] && ARCH="x86"
+
+	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
+		|| die "Configuration application failed"
+}
+
+src_install() {
+	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
+
+	dodir /boot
+	insinto /boot
+	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+	# Package source (kind of annoying because of some packages expecting it)
+	emake clean
+	dodir /usr/src
+	cp -a "${S}" "${D}/usr/src/linux-${PV}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+	(
+	cd "${ROOT}/usr/src"
+	rm -f linux
+	ln -s $(ls | grep "linux-" | sort | tail -1) linux
+	)
+}
+
+sysfile() {
+	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
+	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
+		SYSLINUX="${ROOT}/boot/extlinux.conf"
+	else
+		eerror "Can't locate syslinux configuration!"
+	fi
+}
+
+pkg_postinst() {
+	# Add label to syslinux config if there is non yet
+	sysfile
+	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+		if $(use initramfs); then
+			if $(use ucode); then
+				INITRD="\tINITRD /ucode.cpio,/initramfs-gentoo\n"
+			else
+				INITRD="\tINITRD /initramfs-gentoo\n"
+			fi
+		fi
+		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+		if [ -n "$ARGS" ]; then
+			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+		else
+			eerror "Adding label to syslinux configuration failed as there are no arguments"
+		fi
+	fi
+
+	src_link
+}
+
+pkg_prerm() {
+	# Remove label from syslinux config
+	sysfile
+	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+	src_link
+}
-- 
cgit v1.2.3