From ae194e32eb1a5e4028d8760d06c4e23a3a6c7ee1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Wed, 11 Jul 2018 23:25:26 +0200
Subject: sys-kernel/linux: update to 4.17.6 version

---
 sys-kernel/linux/Manifest               |  2 +-
 sys-kernel/linux/linux-4.17.4-r1.ebuild | 95 ---------------------------------
 sys-kernel/linux/linux-4.17.6-r1.ebuild | 95 +++++++++++++++++++++++++++++++++
 3 files changed, 96 insertions(+), 96 deletions(-)
 delete mode 100644 sys-kernel/linux/linux-4.17.4-r1.ebuild
 create mode 100644 sys-kernel/linux/linux-4.17.6-r1.ebuild

(limited to 'sys-kernel/linux')

diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index 6527cbb..2b5eb4f 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1 +1 @@
-DIST linux-4.17.4.tar.gz 159606669 BLAKE2B 160a80c7cd53a2c1fcf5dab6e28ab34dd3dc2684b0c43099f904548280a64037ed5ed5a7ee6716b4f825c5b27abaf78c8831c521492a491f117ebb297122e415 SHA512 250be1cd3d0e43364fa95a97a33ab8e0af50280fccfe19ceed07f4ec780dd65b37b17010605f173253d13b50b778653e90d9db7d21b969c8150b8f3f2c62d70d
+DIST linux-4.17.6.tar.gz 159616891 BLAKE2B 30f2aece83ba7b30709e2bb8ffd6e42713993d96f0d7a8d3aa1c593198860a4faeabd70304acc5093caa701cdae3482f888d7ad2c7872c04a5b3fb833342f160 SHA512 46ed9eba68c3853c9cf1020e352180697b86e8a0fee09fb9f04778d0973dd4637bd633f53e296cbc9c7d108e6e4392a69ddeeb01560e533d55c71cad326f1e74
diff --git a/sys-kernel/linux/linux-4.17.4-r1.ebuild b/sys-kernel/linux/linux-4.17.4-r1.ebuild
deleted file mode 100644
index a450a55..0000000
--- a/sys-kernel/linux/linux-4.17.4-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="virt initramfs amd intel"
-
-DEPEND="
-	sys-devel/bc
-	dev-libs/elfutils"
-
-src_configure() {
-	# Fix ARCH variable
-	[ "$ARCH" = "amd64" ] && ARCH="x86"
-
-	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
-		|| die "Configuration application failed"
-}
-
-src_install() {
-	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
-	dodir /boot
-	insinto /boot
-	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
-	# Package source (kind of annoying because of some packages expecting it)
-	emake clean
-	dodir /usr/src
-	cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
-	(
-	cd "${ROOT}/usr/src"
-	rm -f linux
-	ln -s $(ls | grep "linux-" | sort | tail -1) linux
-	)
-}
-
-sysfile() {
-	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
-		PFIX=".."
-	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
-		PFIX="../../.."
-	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
-		SYSLINUX="${ROOT}/boot/extlinux.conf"
-		PFIX="."
-	else
-		eerror "Can't locate syslinux configuration!"
-	fi
-}
-
-pkg_postinst() {
-	# Add label to syslinux config if there is non yet
-	sysfile
-	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
-		if $(use initramfs); then
-			INITRD="\tINITRD ${PFIX}/initramfs-gentoo\n"
-		fi
-		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
-		if [ -n "$ARGS" ]; then
-			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
-			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
-		else
-			eerror "Adding label to syslinux configuration failed as there are no arguments"
-		fi
-	fi
-
-	src_link
-}
-
-pkg_prerm() {
-	# Remove label from syslinux config
-	sysfile
-	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
-	src_link
-}
diff --git a/sys-kernel/linux/linux-4.17.6-r1.ebuild b/sys-kernel/linux/linux-4.17.6-r1.ebuild
new file mode 100644
index 0000000..a450a55
--- /dev/null
+++ b/sys-kernel/linux/linux-4.17.6-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-stable-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE="virt initramfs amd intel"
+
+DEPEND="
+	sys-devel/bc
+	dev-libs/elfutils"
+
+src_configure() {
+	# Fix ARCH variable
+	[ "$ARCH" = "amd64" ] && ARCH="x86"
+
+	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
+		|| die "Configuration application failed"
+}
+
+src_install() {
+	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
+
+	dodir /boot
+	insinto /boot
+	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+	# Package source (kind of annoying because of some packages expecting it)
+	emake clean
+	dodir /usr/src
+	cp -a "${S}" "${D}/usr/src/linux-${PV}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+	(
+	cd "${ROOT}/usr/src"
+	rm -f linux
+	ln -s $(ls | grep "linux-" | sort | tail -1) linux
+	)
+}
+
+sysfile() {
+	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+		PFIX=".."
+	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
+		PFIX="../../.."
+	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
+		SYSLINUX="${ROOT}/boot/extlinux.conf"
+		PFIX="."
+	else
+		eerror "Can't locate syslinux configuration!"
+	fi
+}
+
+pkg_postinst() {
+	# Add label to syslinux config if there is non yet
+	sysfile
+	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+		if $(use initramfs); then
+			INITRD="\tINITRD ${PFIX}/initramfs-gentoo\n"
+		fi
+		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+		if [ -n "$ARGS" ]; then
+			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+		else
+			eerror "Adding label to syslinux configuration failed as there are no arguments"
+		fi
+	fi
+
+	src_link
+}
+
+pkg_prerm() {
+	# Remove label from syslinux config
+	sysfile
+	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+	src_link
+}
-- 
cgit v1.2.3