From 1b1975a598241207aeae34e58539e4a98a27b196 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Sun, 2 Sep 2018 21:00:26 +0200
Subject: sys-kernel/linux: update to version 4.17.19

---
 sys-kernel/linux/Manifest                |  2 +-
 sys-kernel/linux/files/overlay.config    |  2 +
 sys-kernel/linux/linux-4.17.18-r1.ebuild | 95 --------------------------------
 sys-kernel/linux/linux-4.17.19-r1.ebuild | 95 ++++++++++++++++++++++++++++++++
 4 files changed, 98 insertions(+), 96 deletions(-)
 delete mode 100644 sys-kernel/linux/linux-4.17.18-r1.ebuild
 create mode 100644 sys-kernel/linux/linux-4.17.19-r1.ebuild

(limited to 'sys-kernel/linux')

diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index 9534644..e2ba651 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1 +1 @@
-DIST linux-4.17.18.tar.gz 159653490 BLAKE2B d46be9b19207cf711044da409579335dd6941889a6393f197f38da67fdadf0f538feacd7c7671346472ee84a04eff8e1bc3b3e1f93e047e607f7f95bb1cd4584 SHA512 110d10892fd506fdc3fb92737cd6bfe0d203e3884c6ed593c5a60c27e01dc9b51008df3b78bc59e8e3671cb9e3e383277092151086fb40e61afe722dc9c4ca70
+DIST linux-4.17.19.tar.gz 159661315 BLAKE2B 0f5ce5a5726e40728c5010b2829ecbf0f0d7e56149ccf8ba7ed3df85e157174d4c9065be96d20084b225deda27971cf54eace3d97fd84fd043c105ee84b25e67 SHA512 31398cf40df250c5d99d265b090a883c8ba3c3c47d509ac1341c3566e3bb64d1b572b78e0f94d697b56f9f361f6e8dbb503be996875821fc15ba8998de82b286
diff --git a/sys-kernel/linux/files/overlay.config b/sys-kernel/linux/files/overlay.config
index 97464ef..bbf909e 100644
--- a/sys-kernel/linux/files/overlay.config
+++ b/sys-kernel/linux/files/overlay.config
@@ -13,6 +13,8 @@ CONFIG_BSD_PROCESS_ACCT_V3=y
 
 # Built in keyboard support
 CONFIG_KEYBOARD_ATKBD=y
+# Add support for roccat keyboard
+CONFIG_HID_ROCCAT=y
 
 # SATA support compile in
 CONFIG_ATA=y
diff --git a/sys-kernel/linux/linux-4.17.18-r1.ebuild b/sys-kernel/linux/linux-4.17.18-r1.ebuild
deleted file mode 100644
index dbd7310..0000000
--- a/sys-kernel/linux/linux-4.17.18-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="virt initramfs amd intel"
-
-DEPEND="
-	sys-devel/bc
-	dev-libs/elfutils"
-
-src_configure() {
-	# Fix ARCH variable
-	[ "$ARCH" = "amd64" ] && ARCH="x86"
-
-	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
-		|| die "Configuration application failed"
-}
-
-src_install() {
-	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
-	dodir /boot
-	insinto /boot
-	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
-	# Package source (kind of annoying because of some packages expecting it)
-	emake clean
-	dodir /usr/src
-	cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
-	(
-	cd "${ROOT}/usr/src"
-	rm -f linux
-	ln -s $(ls | grep "linux-" | sort | tail -1) linux
-	)
-}
-
-sysfile() {
-	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
-		PFIX=".."
-	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
-		PFIX="../../.."
-	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
-		SYSLINUX="${ROOT}/boot/extlinux.conf"
-		PFIX="."
-	else
-		eerror "Can't locate syslinux configuration!"
-	fi
-}
-
-pkg_postinst() {
-	# Add label to syslinux config if there is non yet
-	sysfile
-	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
-		if $(use initramfs); then
-			INITRD="\tINITRD ${PFIX}/initramfs-gentoo\n"
-		fi
-		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
-		if [ -n "$ARGS" ]; then
-			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
-			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
-		else
-			eerror "Adding label to syslinux configuration failed as there are no arguments"
-		fi
-	fi
-
-	src_link
-}
-
-pkg_prerm() {
-	# Remove label from syslinux config
-	sysfile
-	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
-	src_link
-}
diff --git a/sys-kernel/linux/linux-4.17.19-r1.ebuild b/sys-kernel/linux/linux-4.17.19-r1.ebuild
new file mode 100644
index 0000000..dbd7310
--- /dev/null
+++ b/sys-kernel/linux/linux-4.17.19-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE="virt initramfs amd intel"
+
+DEPEND="
+	sys-devel/bc
+	dev-libs/elfutils"
+
+src_configure() {
+	# Fix ARCH variable
+	[ "$ARCH" = "amd64" ] && ARCH="x86"
+
+	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) $(usev virt) \
+		|| die "Configuration application failed"
+}
+
+src_install() {
+	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
+
+	dodir /boot
+	insinto /boot
+	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+	# Package source (kind of annoying because of some packages expecting it)
+	emake clean
+	dodir /usr/src
+	cp -a "${S}" "${D}/usr/src/linux-${PV}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+	(
+	cd "${ROOT}/usr/src"
+	rm -f linux
+	ln -s $(ls | grep "linux-" | sort | tail -1) linux
+	)
+}
+
+sysfile() {
+	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+		PFIX=".."
+	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
+		PFIX="../../.."
+	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
+		SYSLINUX="${ROOT}/boot/extlinux.conf"
+		PFIX="."
+	else
+		eerror "Can't locate syslinux configuration!"
+	fi
+}
+
+pkg_postinst() {
+	# Add label to syslinux config if there is non yet
+	sysfile
+	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+		if $(use initramfs); then
+			INITRD="\tINITRD ${PFIX}/initramfs-gentoo\n"
+		fi
+		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+		if [ -n "$ARGS" ]; then
+			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ${PFIX}/bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+		else
+			eerror "Adding label to syslinux configuration failed as there are no arguments"
+		fi
+	fi
+
+	src_link
+}
+
+pkg_prerm() {
+	# Remove label from syslinux config
+	sysfile
+	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+	src_link
+}
-- 
cgit v1.2.3