From f509365c89258e9e7b7f981ae51289d182e9e958 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Sat, 29 Jul 2017 18:31:16 +0200
Subject: Linux v4.11.12

---
 sys-kernel/linux/Manifest                |  2 +-
 sys-kernel/linux/linux-4.11.11-r1.ebuild | 74 --------------------------------
 sys-kernel/linux/linux-4.11.12-r1.ebuild | 74 ++++++++++++++++++++++++++++++++
 3 files changed, 75 insertions(+), 75 deletions(-)
 delete mode 100644 sys-kernel/linux/linux-4.11.11-r1.ebuild
 create mode 100644 sys-kernel/linux/linux-4.11.12-r1.ebuild

diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index f9c3baa..6d88f05 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1 +1 @@
-DIST linux-4.11.11.tar.gz 147169554 SHA256 68c360f3a30c902a28c77f94c5a9e4a08577b183d6adda7398c88ceb93f75238 SHA512 8819f232853d6c001ef2b62b638ed4817f4b941d766a658d92ae1e2e1cea10abfda82c7cb210d4affb4dfa1fcd653755f5372619ec4518b66b564611f11fead9 WHIRLPOOL 7328e6add970d0e6ed932f538638bbd608ae381d0a05a4866c501992bacba304d50166e433c79806653bde0b880606d26aeff894edbb0d617b3ac78f7fec66f1
+DIST linux-4.11.12.tar.gz 147182467 SHA256 de715ac5e46e161098c89675c3a244af4cb8e351922cbebeeadf7bcc3d700cd2 SHA512 fe578f68c6c975c5954d2d7eb2f07d54f742345dd496e6ffa4f97feb7b64a736f3ae04f37aa88bba48f909c3d9c84527509470988466c339410c5b4cd81f5b28 WHIRLPOOL 858d6b6db764cf448378b8ca55f9cbc3b89f17ba9114c60eefa1b56e2d686da841fb2934087ee9df390191ec5ed8b60ef947900aedb0cc869a7e917dd402186b
diff --git a/sys-kernel/linux/linux-4.11.11-r1.ebuild b/sys-kernel/linux/linux-4.11.11-r1.ebuild
deleted file mode 100644
index 47e48ea..0000000
--- a/sys-kernel/linux/linux-4.11.11-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
-	sys-boot/myinitramfs"
-
-src_configure() {
-	# Fix ARCH variable
-	[ "$ARCH" = "amd64" ] && ARCH="x86"
-
-	"${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
-}
-
-src_install() {
-	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
-	dodir /boot
-	insinto /boot
-	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
-	# Package source (kind of annoying because of some packages expecting it)
-	emake clean
-	dodir /usr/src
-	cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
-	(
-	cd "${ROOT}/usr/src"
-	rm -f linux
-	ln -s $(ls | grep "linux-" | sort | tail -1) linux
-	)
-}
-
-pkg_postinst() {
-	# Add label to syslinux config if there is non yet
-	SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
-	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
-		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
-		if [ -n "$ARGS" ]; then
-			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
-			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
-		else
-			eerror "Adding label to syslinux configuration failed as there are no arguments"
-		fi
-	fi
-	src_link
-}
-
-pkg_prerm() {
-	# Remove label from syslinux config
-	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
-	src_link
-}
diff --git a/sys-kernel/linux/linux-4.11.12-r1.ebuild b/sys-kernel/linux/linux-4.11.12-r1.ebuild
new file mode 100644
index 0000000..47e48ea
--- /dev/null
+++ b/sys-kernel/linux/linux-4.11.12-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-stable-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+	sys-boot/myinitramfs"
+
+src_configure() {
+	# Fix ARCH variable
+	[ "$ARCH" = "amd64" ] && ARCH="x86"
+
+	"${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
+}
+
+src_install() {
+	emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
+
+	dodir /boot
+	insinto /boot
+	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+	# Package source (kind of annoying because of some packages expecting it)
+	emake clean
+	dodir /usr/src
+	cp -a "${S}" "${D}/usr/src/linux-${PV}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+	(
+	cd "${ROOT}/usr/src"
+	rm -f linux
+	ln -s $(ls | grep "linux-" | sort | tail -1) linux
+	)
+}
+
+pkg_postinst() {
+	# Add label to syslinux config if there is non yet
+	SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+		if [ -n "$ARGS" ]; then
+			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+		else
+			eerror "Adding label to syslinux configuration failed as there are no arguments"
+		fi
+	fi
+	src_link
+}
+
+pkg_prerm() {
+	# Remove label from syslinux config
+	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+	src_link
+}
-- 
cgit v1.2.3