From 88537095f4e2431d47a7343a3631b77452832c48 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Tue, 25 Apr 2017 11:58:33 +0200
Subject: Add BBB U-Boot

---
 profiles/bbb-init/packages                  |  1 +
 sys-boot/uboot_bbb/files/uEnv.txt           |  1 +
 sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild | 42 +++++++++++++++++++++++++++++
 3 files changed, 44 insertions(+)
 create mode 100644 profiles/bbb-init/packages
 create mode 100644 sys-boot/uboot_bbb/files/uEnv.txt
 create mode 100644 sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild

diff --git a/profiles/bbb-init/packages b/profiles/bbb-init/packages
new file mode 100644
index 0000000..cfe68c8
--- /dev/null
+++ b/profiles/bbb-init/packages
@@ -0,0 +1 @@
+sys-boot/uboot_bbb
diff --git a/sys-boot/uboot_bbb/files/uEnv.txt b/sys-boot/uboot_bbb/files/uEnv.txt
new file mode 100644
index 0000000..f432efc
--- /dev/null
+++ b/sys-boot/uboot_bbb/files/uEnv.txt
@@ -0,0 +1 @@
+optargs=coherent_pool=1M
diff --git a/sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild b/sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild
new file mode 100644
index 0000000..be1d8a5
--- /dev/null
+++ b/sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Simple serial terminal"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot"
+
+EGIT_REPO_URI="git://git.denx.de/u-boot.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="-* arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+	emake am335x_boneblack_config
+}
+
+src_install() {
+	dodir /boot
+	insinto /boot
+	doins MLO
+	doins u-boot.img
+	doins "${FILESDIR}"/uEnv.txt
+}
+
+pkg_postinst() {
+	ROOT="$(mount | awk '/ on \/ / { print $1; }')"
+	if [[ $ROOT =~ ^/dev/mmcblk.*$ ]]; then
+		ROOT=${ROOT:0:12}
+		elog "Flashing the new U-Boot to boot device."
+		dd if=/boot/MLO of=$ROOT count=1 seek=1 conv=notrunc bs=128k
+		dd if=/boot/u-boot.img of=$ROOT count=2 seek=1 conv=notrunc bs=384k
+	fi
+}
-- 
cgit v1.2.3