From 5a9bf16e797d3871dae474b28c549046f011d089 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Fri, 29 Jan 2021 12:04:19 +0100
Subject: sys-kernel/linux: update to version 5.10.11

---
 sys-kernel/linux/Manifest                |   2 +-
 sys-kernel/linux/linux-5.10.11-r1.ebuild | 107 +++++++++++++++++++++++++++++++
 sys-kernel/linux/linux-5.10.6-r1.ebuild  | 107 -------------------------------
 3 files changed, 108 insertions(+), 108 deletions(-)
 create mode 100644 sys-kernel/linux/linux-5.10.11-r1.ebuild
 delete mode 100644 sys-kernel/linux/linux-5.10.6-r1.ebuild

diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index 8081a9b..ff00b0e 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1 +1 @@
-DIST linux-5.10.6.tar.gz 185331275 BLAKE2B 2aa6eb784d35480c35458b19e5f6a87a8d0e786e2bdb2991149c9b8af0c796a8ed78e0e0fc4728627dfcb57d3bf82c8e9029bba284f89e70207db14752cdf0a3 SHA512 7d5da2b8739200b6d3bf68938161a777c857b46649fa221c32e196fa18571c1bdbfd71cb23968faa996a9de606ad689e571eb3c9c96a081cb8c6c7c63c579520
+DIST linux-5.10.11.tar.gz 185352780 BLAKE2B bee57ff41fbd872703203fbc5256b5031b0383c1e1f4c31482134a8d3a0e3f56380d191b867dbc78218b81687fa5549db5b69a33bb5fa2e2e1391b155d6adadc SHA512 82ded70315d22a0f67daef1c81901d958a8f296abb5002171406b1de07ad9bdcc98978392ec8bfeed453fa7c014cb8f1bb2cf99818dfe7650ea470214058d223
diff --git a/sys-kernel/linux/linux-5.10.11-r1.ebuild b/sys-kernel/linux/linux-5.10.11-r1.ebuild
new file mode 100644
index 0000000..a9d4267
--- /dev/null
+++ b/sys-kernel/linux/linux-5.10.11-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE="amd intel initramfs ucode"
+
+RDEPEND="initramfs? ( sys-boot/myinitramfs )"
+DEPEND="
+	sys-devel/bc
+	dev-libs/elfutils
+	dev-util/dwarves
+"
+
+src_configure() {
+	# Fix ARCH variable
+	[ "$ARCH" = "amd64" ] && ARCH="x86"
+
+	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) \
+		|| die "Configuration application failed"
+}
+
+src_install() {
+	emake modules_install INSTALL_MOD_PATH="${D}"
+	for dir in "build" "source"; do
+		ln -sf "../../../usr/src/${P}" "${D}/lib/modules/${PV}/$dir"
+	done
+
+	dodir /boot
+	insinto /boot
+	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+	# Package source (kind of annoying because of some packages expecting it)
+	emake clean
+	dodir /usr/src
+	cp -a "${S}" "${D}/usr/src/${P}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+	(
+	cd "${ROOT}/usr/src"
+	rm -f linux
+	ln -s $(ls | grep "linux-" | sort | tail -1) linux
+	)
+}
+
+sysfile() {
+	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
+	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
+		SYSLINUX="${ROOT}/boot/extlinux.conf"
+	else
+		eerror "Can't locate syslinux configuration!"
+	fi
+}
+
+pkg_postinst() {
+	# Add label to syslinux config if there is non yet
+	sysfile
+	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+		if $(use initramfs); then
+			if $(use ucode); then
+				INITRD="\tINITRD /ucode.cpio,/initramfs-gentoo\n"
+			else
+				INITRD="\tINITRD /initramfs-gentoo\n"
+			fi
+		fi
+		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+		if [ -n "$ARGS" ]; then
+			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+		else
+			eerror "Adding label to syslinux configuration failed as there are no arguments"
+		fi
+	fi
+
+	src_link
+}
+
+pkg_prerm() {
+	# Remove label from syslinux config
+	sysfile
+	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+	# Remove any residue files
+	rm -rf "/usr/src/${P}" "/lib/modules/${PV}"
+}
+
+pkg_postrm() {
+	src_link
+}
diff --git a/sys-kernel/linux/linux-5.10.6-r1.ebuild b/sys-kernel/linux/linux-5.10.6-r1.ebuild
deleted file mode 100644
index a9d4267..0000000
--- a/sys-kernel/linux/linux-5.10.6-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="amd intel initramfs ucode"
-
-RDEPEND="initramfs? ( sys-boot/myinitramfs )"
-DEPEND="
-	sys-devel/bc
-	dev-libs/elfutils
-	dev-util/dwarves
-"
-
-src_configure() {
-	# Fix ARCH variable
-	[ "$ARCH" = "amd64" ] && ARCH="x86"
-
-	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) \
-		|| die "Configuration application failed"
-}
-
-src_install() {
-	emake modules_install INSTALL_MOD_PATH="${D}"
-	for dir in "build" "source"; do
-		ln -sf "../../../usr/src/${P}" "${D}/lib/modules/${PV}/$dir"
-	done
-
-	dodir /boot
-	insinto /boot
-	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
-	# Package source (kind of annoying because of some packages expecting it)
-	emake clean
-	dodir /usr/src
-	cp -a "${S}" "${D}/usr/src/${P}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
-	(
-	cd "${ROOT}/usr/src"
-	rm -f linux
-	ln -s $(ls | grep "linux-" | sort | tail -1) linux
-	)
-}
-
-sysfile() {
-	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
-	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
-	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
-		SYSLINUX="${ROOT}/boot/extlinux.conf"
-	else
-		eerror "Can't locate syslinux configuration!"
-	fi
-}
-
-pkg_postinst() {
-	# Add label to syslinux config if there is non yet
-	sysfile
-	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
-		if $(use initramfs); then
-			if $(use ucode); then
-				INITRD="\tINITRD /ucode.cpio,/initramfs-gentoo\n"
-			else
-				INITRD="\tINITRD /initramfs-gentoo\n"
-			fi
-		fi
-		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
-		if [ -n "$ARGS" ]; then
-			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
-			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
-		else
-			eerror "Adding label to syslinux configuration failed as there are no arguments"
-		fi
-	fi
-
-	src_link
-}
-
-pkg_prerm() {
-	# Remove label from syslinux config
-	sysfile
-	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
-	# Remove any residue files
-	rm -rf "/usr/src/${P}" "/lib/modules/${PV}"
-}
-
-pkg_postrm() {
-	src_link
-}
-- 
cgit v1.2.3