From 35a721a6c3cd77ccc56de7d6002e6b9475c224bf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Fri, 4 Jun 2021 22:30:37 +0200
Subject: sys-kernel/linux: update to 5.12.9

---
 sys-kernel/linux/Manifest               |   2 +-
 sys-kernel/linux/linux-5.12.6-r1.ebuild | 106 --------------------------------
 sys-kernel/linux/linux-5.12.9-r1.ebuild | 106 ++++++++++++++++++++++++++++++++
 3 files changed, 107 insertions(+), 107 deletions(-)
 delete mode 100644 sys-kernel/linux/linux-5.12.6-r1.ebuild
 create mode 100644 sys-kernel/linux/linux-5.12.9-r1.ebuild

diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index 45e3636..34f6a13 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1 +1 @@
-DIST linux-5.12.6.tar.gz 190372054 BLAKE2B 2402d4a369ea641afaaf4410a7b3e8da6f7f2e784eec7c1cfc12e0f2903144c25e07177f24756be37750683e3e01c9301d1d58da3800674c97c6dc78535a3fad SHA512 db3dcb9de6d03dabd1c87391e456ef35e235a52a32e01c733c3886f8bb41c7877f53ef404b82a3b7dcc537415a341883ab0e7ae39031d9649d7d512bdd3f7fd0
+DIST linux-5.12.9.tar.gz 190372609 BLAKE2B 9620b184c69dae77590252afec43bd15b1975273f143d95760424df4bc6f20cb7b8364b3e5699ebdb174933f38fcb90fc76d74a07ac3aa472a61e3615104f2a5 SHA512 506eb5d580668f016ce0c3b73ccd02231f4a365782b78861c22a9cba63354b461e77e70c934b31080c5fafcf325a854124a62417b717eb2bbf06f25ba702f6c2
diff --git a/sys-kernel/linux/linux-5.12.6-r1.ebuild b/sys-kernel/linux/linux-5.12.6-r1.ebuild
deleted file mode 100644
index 28f2079..0000000
--- a/sys-kernel/linux/linux-5.12.6-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE="amd intel initramfs ucode"
-
-RDEPEND="initramfs? ( sys-boot/myinitramfs )"
-DEPEND="
-	sys-devel/bc
-	dev-libs/elfutils
-	dev-util/dwarves
-"
-
-src_configure() {
-	# Fix ARCH variable
-	[ "$ARCH" = "amd64" ] && ARCH="x86"
-
-	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) \
-		|| die "Configuration application failed"
-}
-
-src_install() {
-	emake modules_install INSTALL_MOD_PATH="${D}"
-	for dir in "build" "source"; do
-		rm "${D}/lib/modules/${PV}/$dir"
-		ln -sf "../../../usr/src/${P}" "${D}/lib/modules/${PV}/$dir"
-	done
-
-	dodir /boot
-	insinto /boot
-	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
-	# Package source (kind of annoying because of some packages expecting it)
-	emake clean
-	dodir /usr/src
-	cp -a "${S}" "${D}/usr/src/${P}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
-	(
-	cd "${ROOT}/usr/src"
-	rm -f linux
-	ln -s $(ls | grep "linux-" | sort | tail -1) linux
-	)
-}
-
-sysfile() {
-	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
-	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
-		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
-	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
-		SYSLINUX="${ROOT}/boot/extlinux.conf"
-	else
-		eerror "Can't locate syslinux configuration!"
-	fi
-}
-
-pkg_postinst() {
-	# Add label to syslinux config if there is non yet
-	sysfile
-	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
-		if $(use initramfs); then
-			if $(use ucode); then
-				INITRD="\tINITRD /ucode.cpio,/initramfs-gentoo\n"
-			else
-				INITRD="\tINITRD /initramfs-gentoo\n"
-			fi
-		fi
-		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
-		if [ -n "$ARGS" ]; then
-			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
-			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
-		else
-			eerror "Adding label to syslinux configuration failed as there are no arguments"
-		fi
-	fi
-
-	src_link
-}
-
-pkg_prerm() {
-	# Remove label from syslinux config
-	sysfile
-	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
-	# Remove any residue files
-	rm -rf "/usr/src/${P}" "/lib/modules/${PV}"
-
-	src_link
-}
diff --git a/sys-kernel/linux/linux-5.12.9-r1.ebuild b/sys-kernel/linux/linux-5.12.9-r1.ebuild
new file mode 100644
index 0000000..28f2079
--- /dev/null
+++ b/sys-kernel/linux/linux-5.12.9-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VER="${PV%-r*}"
+REV="r${PV##*-r}"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/snapshot/linux-${VER}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/linux-${VER}"
+
+LICENSE="GPLv2"
+SLOT="${PV}"
+KEYWORDS="amd64 ~x86"
+IUSE="amd intel initramfs ucode"
+
+RDEPEND="initramfs? ( sys-boot/myinitramfs )"
+DEPEND="
+	sys-devel/bc
+	dev-libs/elfutils
+	dev-util/dwarves
+"
+
+src_configure() {
+	# Fix ARCH variable
+	[ "$ARCH" = "amd64" ] && ARCH="x86"
+
+	"${FILESDIR}"/config_prepare.sh $(usev amd) $(usev intel) \
+		|| die "Configuration application failed"
+}
+
+src_install() {
+	emake modules_install INSTALL_MOD_PATH="${D}"
+	for dir in "build" "source"; do
+		rm "${D}/lib/modules/${PV}/$dir"
+		ln -sf "../../../usr/src/${P}" "${D}/lib/modules/${PV}/$dir"
+	done
+
+	dodir /boot
+	insinto /boot
+	newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
+
+	# Package source (kind of annoying because of some packages expecting it)
+	emake clean
+	dodir /usr/src
+	cp -a "${S}" "${D}/usr/src/${P}"
+}
+
+# Link /usr/src/linux to newest kernel
+src_link() {
+	(
+	cd "${ROOT}/usr/src"
+	rm -f linux
+	ln -s $(ls | grep "linux-" | sort | tail -1) linux
+	)
+}
+
+sysfile() {
+	if [ -f "${ROOT}/boot/syslinux/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
+	elif [ -f "${ROOT}/boot/EFI/BOOT/syslinux.cfg" ]; then
+		SYSLINUX="${ROOT}/boot/EFI/BOOT/syslinux.cfg"
+	elif [ -f "${ROOT}/boot/extlinux.conf" ]; then
+		SYSLINUX="${ROOT}/boot/extlinux.conf"
+	else
+		eerror "Can't locate syslinux configuration!"
+	fi
+}
+
+pkg_postinst() {
+	# Add label to syslinux config if there is non yet
+	sysfile
+	if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
+		if $(use initramfs); then
+			if $(use ucode); then
+				INITRD="\tINITRD /ucode.cpio,/initramfs-gentoo\n"
+			else
+				INITRD="\tINITRD /initramfs-gentoo\n"
+			fi
+		fi
+		ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
+		if [ -n "$ARGS" ]; then
+			sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS}\n$INITRD" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
+			sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX /bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n$INITRD" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+		else
+			eerror "Adding label to syslinux configuration failed as there are no arguments"
+		fi
+	fi
+
+	src_link
+}
+
+pkg_prerm() {
+	# Remove label from syslinux config
+	sysfile
+	sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" "${SYSLINUX}" || eerror "Removing label from syslinux fonfiguration failed!"
+}
+
+pkg_postrm() {
+	# Remove any residue files
+	rm -rf "/usr/src/${P}" "/lib/modules/${PV}"
+
+	src_link
+}
-- 
cgit v1.2.3