From 2a798d60e3441228ae81a11dc79b941c3f93e129 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <karel.koci@nic.cz>
Date: Tue, 17 Sep 2019 09:43:25 +0200
Subject: dev-python/jedi: update to 0.15.1

---
 dev-python/jedi/Manifest           |  2 +-
 dev-python/jedi/jedi-0.13.3.ebuild | 62 --------------------------------------
 dev-python/jedi/jedi-0.15.1.ebuild | 62 ++++++++++++++++++++++++++++++++++++++
 3 files changed, 63 insertions(+), 63 deletions(-)
 delete mode 100644 dev-python/jedi/jedi-0.13.3.ebuild
 create mode 100644 dev-python/jedi/jedi-0.15.1.ebuild

diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index 459d7ba..17457b3 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1 +1 @@
-DIST jedi-0.13.3.tar.gz 361575 BLAKE2B 2eac24178ffb5c8676ae70fd4d15689945d66ef8971cc318821d475c6d08ab3ea65f9d8e2f64a6f5de3a9bedf5e9afd61545c00d1e2a5396529de1697d51ad99 SHA512 b4327a5485cecf8b9a6e403a3f0d8f8484fbb15a32a60fe94c0bbb2f7f2452368a6bfdf4a0fd008fbb8b7d27063eac6d8e52f0f06f237e2009bef196d85dfefb
+DIST jedi-0.15.1.tar.gz 412356 BLAKE2B a7738e8825b3f578db5e64d50cbf65219b4d2f2f81c45cbae9e3dbb858b0e1ef26d76972c112bfae839daaf73bba0d00b30b5708404d16b0385452500a1c2d35 SHA512 0f6e0185f3f10dbc000f09ddfed7b9596fe5dc270682544173dc156d505618ea14f1f44ede5d2357745ab8ded0b15b2788d064ca4db39fe70196982dd0a16893
diff --git a/dev-python/jedi/jedi-0.13.3.ebuild b/dev-python/jedi/jedi-0.13.3.ebuild
deleted file mode 100644
index 354e2b1..0000000
--- a/dev-python/jedi/jedi-0.13.3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/parso-0.3.1[${PYTHON_USEDEP}]"
-DEPEND="
-	dev-python/setuptools[${PYTHON_USEDEP}]
-	doc? ( dev-python/sphinx )
-	test? (
-		dev-python/pytest[${PYTHON_USEDEP}]
-		${RDEPEND}
-	)"
-
-python_prepare_all() {
-	# speed tests are fragile
-	rm test/test_speed.py || die
-
-	# 'path' completion test does not account for 'path' being a valid
-	# package (i.e. dev-python/path-py)
-	# https://github.com/davidhalter/jedi/issues/1210
-	sed -i -e '/path.*not in/d' test/test_evaluate/test_imports.py || die
-
-	# no clue why it fails but we don't really care about .pyc files
-	# without sources anyway
-	rm test/test_evaluate/test_pyc.py || die
-
-	# our very useful patching changes libdir for no good reason
-	sed -i -e "/site_pkg_path/s:'lib':& if virtualenv.version_info >= (3,7) else '$(get_libdir)':" \
-		test/test_evaluate/test_sys_path.py || die
-
-	# this super-secret feature of py3.4 apparently doesn't work for us
-	sed -i -e 's:test_init_extension_module:_&:' \
-		test/test_evaluate/test_extension.py || die
-
-	distutils-r1_python_prepare_all
-}
-
-python_test() {
-	py.test -vv jedi test || die "Tests failed under ${EPYTHON}"
-}
-
-python_compile_all() {
-	use doc && emake -C docs html
-}
-
-python_install_all() {
-	use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
-	distutils-r1_python_install_all
-}
diff --git a/dev-python/jedi/jedi-0.15.1.ebuild b/dev-python/jedi/jedi-0.15.1.ebuild
new file mode 100644
index 0000000..4088306
--- /dev/null
+++ b/dev-python/jedi/jedi-0.15.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/parso-0.5.0[${PYTHON_USEDEP}]"
+DEPEND="
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	doc? ( dev-python/sphinx )
+	test? (
+		dev-python/pytest[${PYTHON_USEDEP}]
+		${RDEPEND}
+	)"
+
+python_prepare_all() {
+	# speed tests are fragile
+	rm test/test_speed.py || die
+
+	# 'path' completion test does not account for 'path' being a valid
+	# package (i.e. dev-python/path-py)
+	# https://github.com/davidhalter/jedi/issues/1210
+	sed -i -e '/path.*not in/d' test/test_evaluate/test_imports.py || die
+
+	# no clue why it fails but we don't really care about .pyc files
+	# without sources anyway
+	rm test/test_evaluate/test_pyc.py || die
+
+	# our very useful patching changes libdir for no good reason
+	sed -i -e "/site_pkg_path/s:'lib':& if virtualenv.version_info >= (3,7) else '$(get_libdir)':" \
+		test/test_evaluate/test_sys_path.py || die
+
+	# this super-secret feature of py3.4 apparently doesn't work for us
+	sed -i -e 's:test_init_extension_module:_&:' \
+		test/test_evaluate/test_extension.py || die
+
+	distutils-r1_python_prepare_all
+}
+
+python_test() {
+	py.test -vv jedi test || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+	use doc && emake -C docs html
+}
+
+python_install_all() {
+	use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+	distutils-r1_python_install_all
+}
-- 
cgit v1.2.3