summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/radicale/Manifest1
-rw-r--r--www-apps/radicale/files/radicale.init.d26
-rw-r--r--www-apps/radicale/radicale-2.1.8.ebuild40
3 files changed, 0 insertions, 67 deletions
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
deleted file mode 100644
index f41297e..0000000
--- a/www-apps/radicale/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST 2.1.8.tar.gz 89769 SHA256 fdf3942973e6778430cf1abbb8c8cb113ff104dd12b47a894642a2ebf6cf5e88 SHA512 70d7c890a733fb27d007fa593d0140bfd3bde1ff46235252a2cdd3ceaf3bc9f998acb62e131f9bc71aa1c55f51c297e4f494cb22f8cba3c5d8d90069e4957c87 WHIRLPOOL 1424f29241f0fff93c697cea1ff171f0c992d93fb4af41b435a2ac46ac052a07756d0fb8d005edcf73f2d2722c7daf71fb6f7fd990d21e47c1c75dab1c9fb56a
diff --git a/www-apps/radicale/files/radicale.init.d b/www-apps/radicale/files/radicale.init.d
deleted file mode 100644
index a59e8d3..0000000
--- a/www-apps/radicale/files/radicale.init.d
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-PIDFILE=/var/run/radicale.pid
-
-depend() {
- use net
- need localmount
-}
-
-start() {
- ebegin "Starting radicale"
- start-stop-daemon --start --quiet --background \
- --user radicale \
- --pidfile ${PIDFILE} --make-pidfile \
- --exec /usr/bin/radicale -- --foreground
- eend $?
-}
-
-stop() {
- ebegin "Stopping radicale"
- start-stop-daemon --stop --quiet \
- --pidfile ${PIDFILE}
- eend $?
-}
diff --git a/www-apps/radicale/radicale-2.1.8.ebuild b/www-apps/radicale/radicale-2.1.8.ebuild
deleted file mode 100644
index bb14539..0000000
--- a/www-apps/radicale/radicale-2.1.8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit eutils distutils-r1 user
-
-DESCRIPTION="A simple CalDAV calendar server"
-HOMEPAGE="http://www.radicale.org/"
-SRC_URI="https://github.com/Kozea/Radicale/archive/${PV}.tar.gz"
-S="${WORKDIR}/Radicale-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/vobject[${PYTHON_USEDEP}]"
-
-UDIR=/var/lib/radicale
-
-pkg_setup() {
- enewgroup radicale
- enewuser radicale -1 -1 ${UDIR} radicale
-}
-
-python_install_all() {
- # init file
- newinitd "${FILESDIR}"/radicale.init.d radicale
-
- # directories
- diropts -m0750
- dodir ${UDIR}
- fowners radicale:radicale ${UDIR}
-
- distutils-r1_python_install_all
-}