summaryrefslogtreecommitdiff
path: root/sys-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux')
-rw-r--r--sys-kernel/linux/Manifest4
-rw-r--r--sys-kernel/linux/linux-4.11.1-r1.ebuild73
-rw-r--r--sys-kernel/linux/linux-4.11.2-r2.ebuild73
-rw-r--r--sys-kernel/linux/linux-4.11.3-r1.ebuild (renamed from sys-kernel/linux/linux-4.10.15-r1.ebuild)0
4 files changed, 1 insertions, 149 deletions
diff --git a/sys-kernel/linux/Manifest b/sys-kernel/linux/Manifest
index 47d2c01..092cb44 100644
--- a/sys-kernel/linux/Manifest
+++ b/sys-kernel/linux/Manifest
@@ -1,3 +1 @@
-DIST linux-4.10.15.tar.gz 145388522 SHA256 14476bfb3e322d912d310bc30ad5b9b7cb6a59dc4ac376f6c2630a5bbac4ebeb SHA512 ec2aad5970aa520976015c98a1538e689af287521f5102f09abf3283e8555b1868246bf115a22d04af2f7530abc7631e74cf1111fdf995b19f02dc4d1b8f342f WHIRLPOOL 75ac92fc2e8ada3d1263fab70e4fbda84d561ae14eb95f35e919179ec34fc60ba73069766d147e6d621b65587909c0d545438e370ae979b428aee5ed2ba75938
-DIST linux-4.11.1.tar.gz 147143534 SHA256 a6a9cb35aa8b2d51b010ca4613e5b064683e6f8b8ccb6267ba880946d9686190 SHA512 b82b0b8658421e98e5566d2a19330f7ef8143f9584bd2abaddb0e7a707174b855b68c6d33e391faa75e1403687d9647fbbf5c18ba8484760c396db6f06af09ed WHIRLPOOL 121c41663ec2e2846fface87ce4a8e631d259c72da3d13d29e81a7f976a8fb2d2616599d33eacb20ac52c9be1cf5ceb0f82d7ab45111197dc8dd4035844a6bcb
-DIST linux-4.11.2.tar.gz 147142058 SHA256 8aa9e8dc52f0e36e83e5658253a2c83b0f7e6a0fe2f2af51b23543fe96ade0ee SHA512 dac36fa05efc6c5b18617b3d19ffe3f75ecdcd0791bfef53151658acf8486afe97ff278756839d400b887b13f781f95f486525780ec2b62fcded8094e74a964e WHIRLPOOL 08029f144e6466b96f65323470dfda0eb802b1110a98143bd382abe1432c112e2c07031ca27346d75154f7b423adfd3c63ab19f879c92bc11ae155bfdddebe6c
+DIST linux-4.11.3.tar.gz 147155032 SHA256 b70c23f6c14d4b2ba8827bcc50b78201e399be7ed39dff92b24a27f82a2d59ee SHA512 9a681dd9dee31419359e1d102644d0180240522df171631c575f0f4becbb8ea8d8589b4972b885fbf8fe971856a1e9ad6736df5db23f471e04c0d9e0c4784380 WHIRLPOOL 4020cf15ae7eb2f341dcce0e07bf8382bf4fb6ca94ba1b20abd66784f84d527868058870f2ac6ec9259c5ed582e68411b74587bba2a55fe8ea717f79ca528309
diff --git a/sys-kernel/linux/linux-4.11.1-r1.ebuild b/sys-kernel/linux/linux-4.11.1-r1.ebuild
deleted file mode 100644
index cece624..0000000
--- a/sys-kernel/linux/linux-4.11.1-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-boot/myinitramfs"
-
-src_configure() {
- # Fix ARCH variable
- [ "$ARCH" = "amd64" ] && ARCH="x86"
-
- "${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
-}
-
-src_install() {
- emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
- dodir /boot
- insinto /boot
- newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
- # Package source (kind of annoying because of some packages expecting it)
- emake clean
- dodir /usr/src
- cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
- (
- cd "${ROOT}/usr/src"
- rm -f linux
- ln -s $(ls | grep "linux-" | sort | tail -1) linux
- )
-}
-
-pkg_postinst() {
- # Add label to syslinux config if there is non yet
- SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
- if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
- ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
- if [ -n "$ARGS" ]; then
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- else
- eerror "Adding label to syslinux configuration failed as there are no arguments"
- fi
- fi
- src_link
-}
-
-pkg_prerm() {
- # Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
- src_link
-}
diff --git a/sys-kernel/linux/linux-4.11.2-r2.ebuild b/sys-kernel/linux/linux-4.11.2-r2.ebuild
deleted file mode 100644
index cece624..0000000
--- a/sys-kernel/linux/linux-4.11.2-r2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-boot/myinitramfs"
-
-src_configure() {
- # Fix ARCH variable
- [ "$ARCH" = "amd64" ] && ARCH="x86"
-
- "${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
-}
-
-src_install() {
- emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
- dodir /boot
- insinto /boot
- newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
- # Package source (kind of annoying because of some packages expecting it)
- emake clean
- dodir /usr/src
- cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
- (
- cd "${ROOT}/usr/src"
- rm -f linux
- ln -s $(ls | grep "linux-" | sort | tail -1) linux
- )
-}
-
-pkg_postinst() {
- # Add label to syslinux config if there is non yet
- SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
- if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
- ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
- if [ -n "$ARGS" ]; then
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- else
- eerror "Adding label to syslinux configuration failed as there are no arguments"
- fi
- fi
- src_link
-}
-
-pkg_prerm() {
- # Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
- src_link
-}
diff --git a/sys-kernel/linux/linux-4.10.15-r1.ebuild b/sys-kernel/linux/linux-4.11.3-r1.ebuild
index cece624..cece624 100644
--- a/sys-kernel/linux/linux-4.10.15-r1.ebuild
+++ b/sys-kernel/linux/linux-4.11.3-r1.ebuild