summaryrefslogtreecommitdiff
path: root/sys-boot/uboot-bbb
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/uboot-bbb')
-rw-r--r--sys-boot/uboot-bbb/files/uEnv.txt1
-rw-r--r--sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-boot/uboot-bbb/files/uEnv.txt b/sys-boot/uboot-bbb/files/uEnv.txt
new file mode 100644
index 0000000..f432efc
--- /dev/null
+++ b/sys-boot/uboot-bbb/files/uEnv.txt
@@ -0,0 +1 @@
+optargs=coherent_pool=1M
diff --git a/sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild b/sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild
new file mode 100644
index 0000000..06ec917
--- /dev/null
+++ b/sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Simple serial terminal"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot"
+
+EGIT_REPO_URI="git://git.denx.de/u-boot.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="-* arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ emake am335x_boneblack_config
+}
+
+src_install() {
+ dodir /boot
+ insinto /boot
+ doins MLO
+ doins u-boot.img
+ doins "${FILESDIR}"/uEnv.txt
+}
+
+pkg_postinst() {
+ ROOT="$(mount | awk '/ on \/ / { print $1; }')"
+ if [[ $ROOT =~ ^/dev/mmcblk.*$ ]]; then
+ ROOT=${ROOT:0:12}
+ elog "Flashing the new U-Boot to boot device."
+ dd if=/boot/MLO of=$ROOT count=1 seek=1 conv=notrunc bs=128k
+ dd if=/boot/u-boot.img of=$ROOT count=2 seek=1 conv=notrunc bs=384k
+ else
+ ewarn "Root not detected. Please flash new U-Boot version by hand."
+ fi
+}