summaryrefslogtreecommitdiff
path: root/sys-boot/myinitramfs/myinitramfs-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/myinitramfs/myinitramfs-1.0.ebuild')
-rw-r--r--sys-boot/myinitramfs/myinitramfs-1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-boot/myinitramfs/myinitramfs-1.0.ebuild b/sys-boot/myinitramfs/myinitramfs-1.0.ebuild
new file mode 100644
index 0000000..9e8e999
--- /dev/null
+++ b/sys-boot/myinitramfs/myinitramfs-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO support encrytion and btrfs only as option
+
+EAPI=6
+
+DESCRIPTION="My personal initramfs (verry simple with encryption support)"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-fs/cryptsetup
+sys-fs/btrfs-progs
+sys-apps/linux-misc-apps
+sys-apps/busybox[static]"
+RDEPEND="${DEPENDS}"
+
+src_unpack() {
+ # Well we have no sources so just create empty directory
+ mkdir -p "${S}"
+}
+
+src_compile() {
+ # TODO generate list dynamically
+ cp "${FILESDIR}"/list list
+ echo "file /init ${FILESDIR}/init 755 0 0" >> list
+ gen_init_cpio list > initramfs.cpio
+ gzip initramfs.cpio
+}
+
+src_install() {
+ dodir /boot
+ insinto /boot
+ newins initramfs.cpio.gz initramfs-gentoo
+}