summaryrefslogtreecommitdiff
path: root/sys-apps/shellrc/shellrc-0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/shellrc/shellrc-0.3-r1.ebuild')
-rw-r--r--sys-apps/shellrc/shellrc-0.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/shellrc/shellrc-0.3-r1.ebuild b/sys-apps/shellrc/shellrc-0.3-r1.ebuild
new file mode 100644
index 0000000..9f32ce6
--- /dev/null
+++ b/sys-apps/shellrc/shellrc-0.3-r1.ebuild
@@ -0,0 +1,41 @@
+EAPI=6
+
+DESCRIPTION="Shell initialization files"
+HOMEPAGE="https://git.cynerd.cz/shellrc/"
+SRC_URI="https://git.cynerd.cz/shellrc/snapshot/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="desktop +zsh +bash"
+
+DEPEND="zsh? ( app-shells/zsh )
+ bash? ( app-shells/bash )
+ desktop? ( x11-misc/xclip media-gfx/imagemagick )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodir /etc
+ insinto /etc
+ doins -r "${S}/shellrc.d"
+
+ if use bash; then
+ dodir /etc/bash/bashrc.d
+ insinto /etc/bash
+ doins -r "${S}/bashrc.d"
+ dodir /usr/share/bash-completion/completions
+ insinto /usr/share/bash-completion/completions
+ doins -r "${S}"/bash-completion/*
+ fi
+
+ if use zsh; then
+ dodir /etc/zsh
+ insinto /etc/zsh
+ doins "${S}/zshrc"
+ doins -r "${S}/zshrc.d"
+ dodir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/site-functions
+ doins -r "${S}"/zsh-completion/*
+ fi
+}