summaryrefslogtreecommitdiff
path: root/net-dns
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dyndnsc/dyndnsc-0.5.1-r1.ebuild6
-rw-r--r--net-dns/dyndnsc/files/no-pytest.patch12
2 files changed, 18 insertions, 0 deletions
diff --git a/net-dns/dyndnsc/dyndnsc-0.5.1-r1.ebuild b/net-dns/dyndnsc/dyndnsc-0.5.1-r1.ebuild
index cacb7ce..556bbe2 100644
--- a/net-dns/dyndnsc/dyndnsc-0.5.1-r1.ebuild
+++ b/net-dns/dyndnsc/dyndnsc-0.5.1-r1.ebuild
@@ -19,6 +19,12 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/requests-2.0.1"
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}/no-pytest.patch"
+ distutils-r1_src_prepare
+}
+
src_install() {
distutils-r1_src_install
newinitd "${FILESDIR}/dyndnsc.init" dyndnsc
diff --git a/net-dns/dyndnsc/files/no-pytest.patch b/net-dns/dyndnsc/files/no-pytest.patch
new file mode 100644
index 0000000..f8f45d4
--- /dev/null
+++ b/net-dns/dyndnsc/files/no-pytest.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 67da701..810cae8 100644
+--- a/setup.py
++++ b/setup.py
+@@ -90,7 +90,6 @@ setup(
+ url="https://github.com/infothrill/python-dyndnsc",
+ # https://packaging.python.org/tutorials/distributing-packages/#python-requires
+ python_requires=">=3.5",
+- setup_requires=["pytest-runner"],
+ install_requires=INSTALL_REQUIRES,
+ extras_require=EXTRAS_REQUIRE,
+ entry_points={