summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtstyleplugin/note2
-rw-r--r--dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild40
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-qt/qtstyleplugin/note b/dev-qt/qtstyleplugin/note
deleted file mode 100644
index 3206f62..0000000
--- a/dev-qt/qtstyleplugin/note
+++ /dev/null
@@ -1,2 +0,0 @@
-we should ensure that this is rebuild together with qt libraries. (probably it
-should be qt5-build instead of qmake-utils)
diff --git a/dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild b/dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild
deleted file mode 100644
index 3d21e6f..0000000
--- a/dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit qmake-utils git-r3
-
-DESCRIPTION="Additional style plugins for Qt5 (gtk2, cleanlook, plastic, motif)"
-HOMEPAGE="https://code.qt.io/cgit/qt/qtstyleplugins.git/"
-EGIT_REPO_URI="https://code.qt.io/qt/qtstyleplugins.git"
-EGIT_COMMIT="335dbece103e2cbf6c7cf819ab6672c2956b17b3"
-
-LICENSE="LGPL-2"
-SLOT="5"
-KEYWORDS="x86 amd64"
-
-DEPEND="
- dev-qt/qtgui:5=
- x11-libs/gtk+:2
- dev-qt/qtdbus:5
- x11-libs/libX11"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- eqmake5
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-}
-
-pkg_postinst() {
- elog ""
- elog "To make Qt5 applications use the gtk2 style"
- elog "insert the following into ~/.profile:"
- elog "QT_QPA_PLATFORMTHEME=gtk2"
- elog "For environments using ~/.pam_environment (gnome wayland):"
- elog "QT_QPA_PLATFORMTHEME OVERRIDE=gtk2"
- elog ""
-}