summaryrefslogtreecommitdiff
path: root/dev-python/vobject
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vobject')
-rw-r--r--dev-python/vobject/Manifest1
-rw-r--r--dev-python/vobject/vobject-0.9.6.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/vobject/Manifest b/dev-python/vobject/Manifest
new file mode 100644
index 0000000..60bbe79
--- /dev/null
+++ b/dev-python/vobject/Manifest
@@ -0,0 +1 @@
+DIST vobject-0.9.6.1.tar.gz 216565 BLAKE2B 3097c3291337299f12d015a75509b0d3f14a1cd452f90e4445c3804d2ac8db0ea5858a3674eb688f66aaa5c048b155675fe36513a78b16714aa7bff2a0fd86b2 SHA512 499f22a1a9e60398a89d3d6fa472a0b4c9dd00b98440a4ce873da824f83cef1b0a5eb9e5051267931707a3eef00a1d3fb83ff63ffe857b403c4ac3a131f18dff
diff --git a/dev-python/vobject/vobject-0.9.6.1.ebuild b/dev-python/vobject/vobject-0.9.6.1.ebuild
new file mode 100644
index 0000000..51f3dea
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="http://eventable.github.io/vobject/
+ https://pypi.org/project/vobject/
+ https://github.com/eventable/vobject"
+SRC_URI="https://github.com/eventable/vobject/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools"[${PYTHON_USEDEP}]
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Testing failed under ${EPYTHON}"
+}