summaryrefslogtreecommitdiff
path: root/dev-python/ruamel_yaml/ruamel_yaml-0.15.35.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ruamel_yaml/ruamel_yaml-0.15.35.ebuild')
-rw-r--r--dev-python/ruamel_yaml/ruamel_yaml-0.15.35.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ruamel_yaml/ruamel_yaml-0.15.35.ebuild b/dev-python/ruamel_yaml/ruamel_yaml-0.15.35.ebuild
new file mode 100644
index 0000000..488effc
--- /dev/null
+++ b/dev-python/ruamel_yaml/ruamel_yaml-0.15.35.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+DESCRIPTION="YAML parser/emitter"
+HOMEPAGE="https://bitbucket.org/ruamel/yaml"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+if [ "${PV}" == "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://bitbucket.org/ruamel/yaml"
+else
+ SRC_URI="https://bitbucket.org/ruamel/yaml/get/${PV}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ distutils-r1_src_install
+}