summaryrefslogtreecommitdiff
path: root/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/icalendar/icalendar-4.0.3-r1.ebuild')
-rw-r--r--dev-python/icalendar/icalendar-4.0.3-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/icalendar/icalendar-4.0.3-r1.ebuild b/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
deleted file mode 100644
index f903290..0000000
--- a/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
-HOMEPAGE="https://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc test"
-DOCS="README.rst"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # reset conf.py to not read version from an installed instance
- sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
- -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs text
- DOCS=( ${DOCS} docs/_build/text/*.txt )
- fi
-}
-
-python_test() {
- # From tox.ini
- coverage run --source=src/icalendar --omit=*/tests/* --module \
- pytest src/icalendar || die "test failed under ${EPYTHON}"
-}