summaryrefslogtreecommitdiff
path: root/dev-python/daemonocle/daemonocle-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/daemonocle/daemonocle-1.0.2.ebuild')
-rw-r--r--dev-python/daemonocle/daemonocle-1.0.2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/daemonocle/daemonocle-1.0.2.ebuild b/dev-python/daemonocle/daemonocle-1.0.2.ebuild
new file mode 100644
index 0000000..c7260c5
--- /dev/null
+++ b/dev-python/daemonocle/daemonocle-1.0.2.ebuild
@@ -0,0 +1,18 @@
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Library for creating your own Unix-style daemons"
+HOMEPAGE="http://github.com/jnrbsn/daemonocle"
+SRC_URI="https://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/click
+ dev-python/psutil"
+DEPEND="${RDEPEND}"