summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-compat/Manifest1
-rw-r--r--dev-lua/lua-compat/lua-compat-0.3.ebuild41
-rw-r--r--dev-lua/luaposix/Manifest1
-rw-r--r--dev-lua/luaposix/luaposix-34.0.4.ebuild20
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-lua/lua-compat/Manifest b/dev-lua/lua-compat/Manifest
new file mode 100644
index 0000000..1b97b26
--- /dev/null
+++ b/dev-lua/lua-compat/Manifest
@@ -0,0 +1 @@
+DIST lua-compat-0.3.tar.gz 22407 BLAKE2B f8fa3aba2aab85b701c688a771e59b664c6541d1048c8e9d9a846e4458fffff451fba40f72f5e6d4310f533d860269e07f5135d3f44aa1b61de9755df8c2834a SHA512 b6b70162d5b25e3cc646613ee62a8f136903b4e0ae749285105429cce0e5d3eebc3295aa98749239651dd67d5ee55199172267cefb1588969093770a7e82ac96
diff --git a/dev-lua/lua-compat/lua-compat-0.3.ebuild b/dev-lua/lua-compat/lua-compat-0.3.ebuild
new file mode 100644
index 0000000..3312df8
--- /dev/null
+++ b/dev-lua/lua-compat/lua-compat-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua-5.2-style APIs for Lua 5.1"
+HOMEPAGE="https://github.com/keplerproject/lua-compat-5.2"
+SRC_URI="https://github.com/keplerproject/lua-compat-5.2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bit32 +compat52"
+
+RDEPEND="dev-lang/lua:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lua-compat-5.2-0.3"
+
+src_compile() {
+ if use bit32; then
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o bit32.so lbitlib.c c-api/compat-5.2.c || die
+ fi
+}
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/term
+ if use bit32; then
+ doins bit32.so
+ fi
+ if use compat52; then
+ doins compat52.lua
+ newins compat52/strict.lua compat52.strict.lua
+ newins compat52/mstrict.lua compat52.mstrict.lua
+ fi
+}
+
diff --git a/dev-lua/luaposix/Manifest b/dev-lua/luaposix/Manifest
new file mode 100644
index 0000000..26cc516
--- /dev/null
+++ b/dev-lua/luaposix/Manifest
@@ -0,0 +1 @@
+DIST luaposix-34.0.4.tar.gz 175204 BLAKE2B 4ecbf0c222d95c42d2e4f14aca318c18f6fbc585084de0149201295e9c3f4789d3fdcb23991d0c969560701eb75506905390f9388679e53fd6bc79da78a82f8f SHA512 d97690d3a9dd1941ab8c1e94627cafadff19080c2f6633ce363b2f3a33b76f856ce1f55acaa916254d094179e4ffd130ab7caa30e3b930d04219740967494f55
diff --git a/dev-lua/luaposix/luaposix-34.0.4.ebuild b/dev-lua/luaposix/luaposix-34.0.4.ebuild
new file mode 100644
index 0000000..0c940da
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-34.0.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:0=
+ dev-lang/lua-compat[bit32]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-release-v${PV}