summaryrefslogtreecommitdiff
path: root/dev-libs/sway/sway-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/sway/sway-1.0-r1.ebuild')
-rw-r--r--dev-libs/sway/sway-1.0-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-libs/sway/sway-1.0-r1.ebuild b/dev-libs/sway/sway-1.0-r1.ebuild
deleted file mode 100644
index ae68063..0000000
--- a/dev-libs/sway/sway-1.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils meson ninja-utils
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="http://swaywm.org/"
-
-SRC_URI="https://github.com/swaywm/sway/archive/1.0-beta.1.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sway-1.0-beta.1"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-# TODO
-IUSE="wallpapers bash-completion zsh-completion +xwayland"
-
-RDEPEND="
- dev-libs/wlroots
- xwayland? ( dev-libs/wlroots[x11-backend] )
- dev-libs/wayland
- x11-base/xorg-server[wayland]
- >=dev-libs/libinput-1.6.0
- sys-libs/libcap
- dev-libs/libpcre
- >=dev-libs/json-c-0.13:0=
- x11-libs/pango
- x11-libs/cairo
- x11-libs/gdk-pixbuf[jpeg]
- virtual/pam
- >=sys-apps/dbus-1.10
- "
-
-DEPEND="${RDEPEND}
- dev-util/meson
- app-text/scdoc
- virtual/pkgconfig"
-
-src_configure() {
- local emesonargs=(
- -Ddefault-wallpaper=$(usex wallpapers true false)
- -Dzsh-completions=$(usex zsh-completion true false)
- -Dbash-completions=$(usex bash-completion true false)
- -Denable-xwayland=$(usex xwayland true false)
- )
- meson_src_configure
-}