summaryrefslogtreecommitdiff
path: root/dev-embedded/libftd2xx/libftd2xx-1.4.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/libftd2xx/libftd2xx-1.4.8-r1.ebuild')
-rw-r--r--dev-embedded/libftd2xx/libftd2xx-1.4.8-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-embedded/libftd2xx/libftd2xx-1.4.8-r1.ebuild b/dev-embedded/libftd2xx/libftd2xx-1.4.8-r1.ebuild
new file mode 100644
index 0000000..964f1c5
--- /dev/null
+++ b/dev-embedded/libftd2xx/libftd2xx-1.4.8-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit multilib
+
+DESCRIPTION="Library that allows a direct access to a USB device"
+HOMEPAGE="http://www.ftdichip.com/Drivers/D2XX.htm"
+SRC_URI="
+ amd64? ( https://www.ftdichip.com/Drivers/D2XX/Linux/${PN}-x86_64-${PV}.gz -> ${P}-amd64.tar.gz )
+ x86? ( https://www.ftdichip.com/Drivers/D2XX/Linux/${PN}-i386-${PV}.gz -> ${P}-x86.tar.gz )
+"
+S="${WORKDIR}/release"
+
+LICENSE="FTDI LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+src_install() {
+ dolib.so "${S}/build/${PN}.so.${PV}"
+ dosym "${PN}.so.${PV}" "/usr/$(get_libdir)/${PN}.so.${PV:0:1}"
+ dosym "${PN}.so.${PV}" "/usr/$(get_libdir)/${PN}.so"
+ dolib.a "${S}/build/libftd2xx.a"
+ doheader "${S}"/{ftd2xx,WinTypes}.h
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/sample
+ doins -r "${S}/examples"
+ fi
+
+ dodoc "${S}/ReadMe.txt"
+}