summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/lbry/Manifest1
-rw-r--r--net-p2p/lbry/lbry-0.50.2.ebuild38
-rw-r--r--profiles/desktop/packages1
3 files changed, 40 insertions, 0 deletions
diff --git a/net-p2p/lbry/Manifest b/net-p2p/lbry/Manifest
new file mode 100644
index 0000000..9f3f44a
--- /dev/null
+++ b/net-p2p/lbry/Manifest
@@ -0,0 +1 @@
+DIST lbry-0.50.2.deb 171020830 BLAKE2B b6c54dcbc0dd49bc615cbcea97e3d1620c2c47b7fac6e0250ed366377d3b915bceaf0e185eacd2f4241057370c048cce0f6c3041fb6d4ad051ded5d05f0a957b SHA512 034726bdc634e5fc6d7b74f1accd6976f0299a5115eb4dc34de3973071d69db317970e88a42c7246dbc417823beb71906c0b394d09b8a216f52cef1e3a83f696
diff --git a/net-p2p/lbry/lbry-0.50.2.ebuild b/net-p2p/lbry/lbry-0.50.2.ebuild
new file mode 100644
index 0000000..1a4446e
--- /dev/null
+++ b/net-p2p/lbry/lbry-0.50.2.ebuild
@@ -0,0 +1,38 @@
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="A browser for the LBRY network, a digital marketplace controlled by its users."
+HOMEPAGE="https://lbry.com/"
+SRC_URI="https://github.com/lbryio/lbry-desktop/releases/download/v${PV}/LBRY_${PV}.deb -> ${P}.deb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+QA_PREBUILT="*"
+
+RDEPEND="
+ dev-libs/libappindicator
+ dev-libs/nss
+ gnome-base/gconf
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/libnotify
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ unpack "${S}"/data.tar.xz
+ rm "${S}"/{control,data,debian}* || die
+}
+
+src_install() {
+ doins -r *
+ rm -rd "${ED}"/usr/share/doc || die
+ fperms 0755 /opt/LBRY/lbry || die
+ fperms 0755 /opt/LBRY/resources/static/daemon/lbrynet || die
+}
diff --git a/profiles/desktop/packages b/profiles/desktop/packages
index 9b10049..47b017b 100644
--- a/profiles/desktop/packages
+++ b/profiles/desktop/packages
@@ -92,6 +92,7 @@ media-gfx/shotwell
media-sound/id3tool
#app-text/calibre
net-misc/youtube-dl
+net-p2p/lbry
# Calculations and such
#sci-mathematics/octave