summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python3-prctl/python3-prctl-1.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python3-prctl/python3-prctl-1.6.1.ebuild b/dev-python/python3-prctl/python3-prctl-1.6.1.ebuild
new file mode 100644
index 0000000..81dfbf2
--- /dev/null
+++ b/dev-python/python3-prctl/python3-prctl-1.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}