summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
deleted file mode 100644
index 12f5d0b..0000000
--- a/dev-vcs/python-gitlab/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST python-gitlab-1.15.0.tar.gz 124795 BLAKE2B 5814aefebdae83a18b1274bc8610916eadc9c557166c9ad5fac2e2e48147920854090dbad146dca65332ba4ef0a1ad8ed1bb14e4c22872459f3b44923c3a9de9 SHA512 622804ee580ceef7e37f2645267e723a70b9cb4352e29bb5bd02150894df13df3facf8afb29bdfd1d8b4e1a4438f82bd93e7a9abf6861758c1151e5d2c3202c6
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild
deleted file mode 100644
index e53b651..0000000
--- a/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7,8} )
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Python command line interface to gitlab API"
-HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="test"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/testrepository[${PYTHON_USEDEP}]
- dev-python/hacking[${PYTHON_USEDEP}]
- dev-python/httmock[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.3
- dev-python/sphinx_rtd_theme )"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r *.rst docs
-}