summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libwpe/Manifest1
-rw-r--r--net-libs/libwpe/libwpe-1.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libwpe/Manifest b/net-libs/libwpe/Manifest
new file mode 100644
index 0000000..f033484
--- /dev/null
+++ b/net-libs/libwpe/Manifest
@@ -0,0 +1 @@
+DIST libwpe-1.4.0.tar.xz 49572 BLAKE2B 9172a8ae56a25a5924b4740e0dfc7f38c0f70520c18f328637be148fa65d9dd78440454962ec1358fdf7143dec55d71db65862cc2897bb08f1053ea4316bde80 SHA512 096db1f03357158bf7191543bdcc5cfe5b3b192766fb8ac8c2588e8d4cc837be815b19d65a746981550eafddf513c2b88c2da0e673472cd03e5d43781e6a6d6c
diff --git a/net-libs/libwpe/libwpe-1.4.0.ebuild b/net-libs/libwpe/libwpe-1.4.0.ebuild
new file mode 100644
index 0000000..ae14e0c
--- /dev/null
+++ b/net-libs/libwpe/libwpe-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="General-purpose library for WPE WebKit"
+HOMEPAGE="https://www.wpewebkit.org"
+SRC_URI="https://www.wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}