summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/base/armv7a/bbb/packages3
-rw-r--r--profiles/base/armv7a/rb2/packages2
-rw-r--r--sys-boot/uboot-bbb/files/uEnv.txt (renamed from sys-boot/uboot_bbb/files/uEnv.txt)0
-rw-r--r--sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild (renamed from sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild)2
-rw-r--r--sys-kernel/linux-bbb/linux-bbb-4.9.24.ebuild36
-rw-r--r--sys-kernel/linux-rb2/Manifest (renamed from sys-kernel/linux-raspberry2/Manifest)0
-rw-r--r--sys-kernel/linux-rb2/linux-raspberry2-4.10.13-r1.ebuild (renamed from sys-kernel/linux-raspberry2/linux-raspberry2-4.10.13-r1.ebuild)1
7 files changed, 41 insertions, 3 deletions
diff --git a/profiles/base/armv7a/bbb/packages b/profiles/base/armv7a/bbb/packages
index cfe68c8..9fdc576 100644
--- a/profiles/base/armv7a/bbb/packages
+++ b/profiles/base/armv7a/bbb/packages
@@ -1 +1,2 @@
-sys-boot/uboot_bbb
+sys-boot/uboot-bbb
+sys-kernel/linux-bbb
diff --git a/profiles/base/armv7a/rb2/packages b/profiles/base/armv7a/rb2/packages
index e0069b6..91686f9 100644
--- a/profiles/base/armv7a/rb2/packages
+++ b/profiles/base/armv7a/rb2/packages
@@ -1,3 +1,3 @@
-sys-kernel/linux-raspberry2
+sys-kernel/linux-rb2
sys-kernel/raspberrypi-image
media-libs/raspberrypi-userland
diff --git a/sys-boot/uboot_bbb/files/uEnv.txt b/sys-boot/uboot-bbb/files/uEnv.txt
index f432efc..f432efc 100644
--- a/sys-boot/uboot_bbb/files/uEnv.txt
+++ b/sys-boot/uboot-bbb/files/uEnv.txt
diff --git a/sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild b/sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild
index be1d8a5..06ec917 100644
--- a/sys-boot/uboot_bbb/uboot_bbb-2016.11.ebuild
+++ b/sys-boot/uboot-bbb/uboot-bbb-2016.11.ebuild
@@ -38,5 +38,7 @@ pkg_postinst() {
elog "Flashing the new U-Boot to boot device."
dd if=/boot/MLO of=$ROOT count=1 seek=1 conv=notrunc bs=128k
dd if=/boot/u-boot.img of=$ROOT count=2 seek=1 conv=notrunc bs=384k
+ else
+ ewarn "Root not detected. Please flash new U-Boot version by hand."
fi
}
diff --git a/sys-kernel/linux-bbb/linux-bbb-4.9.24.ebuild b/sys-kernel/linux-bbb/linux-bbb-4.9.24.ebuild
new file mode 100644
index 0000000..e1b34fe
--- /dev/null
+++ b/sys-kernel/linux-bbb/linux-bbb-4.9.24.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GIT_REV="1b71b361146507b1e0c7922d05deb9164382ca66"
+
+DESCRIPTION="Linux kernel"
+HOMEPAGE="http://kernel.org/"
+SRC_URI="https://codeload.github.com/beagleboard/linux/zip/${GIT_REV} -> ${P}.zip"
+S="${WORKDIR}/linux-${GIT_REV}"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="-* arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ emake bb.org_defconfig
+}
+
+src_compile() {
+ emake uImage dtbs modules LOADADDR=0x82000000
+}
+
+src_install() {
+ emake modules_install INSTALL_MOD_PATH="${D}"
+
+ dodir /boot
+ insinto /boot
+ doins "${S}/arch/arm/boot/zImage"
+ doins "arch/arm/boot/dts/am335x-boneblack.dtb"
+}
diff --git a/sys-kernel/linux-raspberry2/Manifest b/sys-kernel/linux-rb2/Manifest
index 1a51c11..1a51c11 100644
--- a/sys-kernel/linux-raspberry2/Manifest
+++ b/sys-kernel/linux-rb2/Manifest
diff --git a/sys-kernel/linux-raspberry2/linux-raspberry2-4.10.13-r1.ebuild b/sys-kernel/linux-rb2/linux-raspberry2-4.10.13-r1.ebuild
index 46f61ff..8c7fbde 100644
--- a/sys-kernel/linux-raspberry2/linux-raspberry2-4.10.13-r1.ebuild
+++ b/sys-kernel/linux-rb2/linux-raspberry2-4.10.13-r1.ebuild
@@ -20,7 +20,6 @@ RDEPEND="${DEPEND}"
src_configure() {
emake bcm2709_defconfig
- emake oldconfig
}
src_install() {